Finding and Replacing

To search through the currently open file:

  1. Press Ctrl+F or select Edit > Find/Replace > Find/Replace.
  2. Enter the text you are looking for.

    If the text is found, all occurrences are highlighted as you type.

  3. To go to the next occurrence, click (Find Next), or press F3. To go to the previous occurrence click (Find Previous), or press Shift+F3.

You can restrict the search in the Find field by selecting one or several search criteria:

  • To make your search case sensitive, select Case Sensitive.
  • To search only whole words, select Whole Words Only.
  • To search using regular expressions, select Use Regular Expressions. Regular expressions used in Qt Creator are modeled on Perl regular expressions. For more information on using regular expressions, see the documentation for the QRegularExpression Class.

Note: If you have selected text before selecting Find/Replace, the search is conducted within the selection.

To replace occurrences of the existing text, enter the new text in the Replace with field.

  • To replace the selected occurrence and move to the next one, click Find Next or press Ctrl+=.
  • To replace the selected occurrence and move to the previous one, click Find Previous.
  • To replace all occurrences in the file, click Replace All.

The Preserve Case when Replacing option can be selected to preserve the case of the original text when replacing. This option is not compatible with the Use Regular Expressions search option, and will thus be disabled when regular expressions are used. When the option is used, the case of the occurrence will be conserved, according to the following rules:

  • All upper-case occurrences are replaced with the upper-case new text.
  • All lower-case occurrences are replaced with the lower-case new text.
  • Capitalized occurrences are replaced with the capitalized new text.
  • Other occurrences are replaced with the new text as entered.
  • If an occurrence and the new text have the same prefix or suffix, then the case of the prefix and/or suffix are preserved, and the other rules are applied on the rest of the occurrence only.

The locations of search hits, breakpoints, and bookmarks in your document are highlighted on the editor scroll bar. To turn highlighting off, select Tools > Options > Text Editor > Display > Highlight search results on the scrollbar.

To search through projects, files on a file system or currently open files:

  1. Press Ctrl+Shift+F or select Edit > Find/Replace > Advanced Find > Open Advanced Find.
  2. Select the scope of your search:
    • All Projects searches files matching the defined file pattern in all currently open projects.

      For example, to search for a string only in .cpp and .h files, enter in File pattern *.cpp,*.h.

    • Current Project searches files matching the defined file pattern only in the project you are currently editing.
    • Files in File System recursively searches files matching the defined file pattern in the selected directory.

      Select the Use Git Grep check box to use Git to only search tracked files in the Git work tree. To restrict the search to the HEAD, a tag, a local or remote branch, or a commit hash, enter a reference in the field. Leave the field empty to search through the file system.

    • Current File searches only the current file.
    • Open Documents searches all open files.
  3. Enter the text you are looking for and click Search.

    A list of files containing the searched text is displayed in the Search Results pane.

    • To see all occurrences in a file, double-click the file name in the list.
    • To go to an occurrence, double-click it.
    • To repeat the search after you have made changes to the listed files, for example, select Search Again.

The search results are stored in the search history from which you can select earlier searches.

Note: You can use Advanced Find also to search for symbols. For more information, see Finding Symbols.

© 2017 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.