Opening Projects

Qt Creator stores information that it needs to build projects in a .user file. If Qt Creator cannot find the file when you open an existing project, it prompts you to enter the information. If you created the project by using another Qt Creator instance, Qt Creator asks whether you want to use the old settings. The settings are specific to the development environment, and should not be copied from one environment to another. Therefore, we recommend that you click No and enter the information again in the Configure Project tab.

The Configure Project tab displays a list of kits for building and running projects, that are installed on the development PC and configured in Tools > Options > Build & Run > Kits. Select the kits that you want to build and run the project with.

"Configure Project tab"

Even if you do not intend to build the project, the C++ and QML code models need a Qt version and compiler to offer code completion. To specify them, select the Options link, or select Tools > Options > Build & Run > Kits.

If Qt Creator cannot find an existing build for a particular kit, it starts out from a clean slate, and creates new debug and release build configurations in the specified directory. Qt Creator suggests a name and location for the directory that you can change.

If you have built the project before, Qt Creator can use the existing build configuration to make the exact same build as found in the directory available to Qt Creator. To import a build, specify a directory in the Import Build from section and select Import.

You can edit the build configuration later. For more information, see Editing Build Configurations.

To open a project:

  1. Select File > Open File or Project and select the project to open.
  2. In the Configure Project tab, select kits for building and running your project, and click Configure Project.

Qt Creator parses all the source files in the project and performs a semantic analysis to build up the information that it needs for functions such as navigation and finding usages. A progress bar is displayed during parsing. To show or hide detailed progress information, select Toggle Progress Details (1).

"Toggle Progress Details button"

© 2016 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.