Using Perforce

Perforce is a fast software configuration management system developed by Perforce Software.

Configuring Perforce

When you start Qt Creator, it looks for the executable specified in the P4 command field in Tools > Options > Version Control > Perforce. If the file is not found, the following error message is displayed in the Version Control output pane: Perforce: Unable to determine the repository: "p4.exe" terminated with exit code 1. If you use Perforce, check that the path to the executable is specified correctly in the P4 command field.

If you do not use Perforce, you can disable the Perforce plugin to get rid of the error message. Choose Help > About Plugins and deselect the Load check box for the Perforce plugin in the Version Control group.

In the Perforce options, you can specify workspace details: P4 user, P4 client, and P4 port. To specify the details individually for several projects, use configuration files instead. Create a p4config.txt configuration file for each project in the top level project directory.

Editing Files

In addition to the standard version control system functions described in Using Common Functions, you can select Tools > Perforce > Edit File to open a file for editing within the client workspace. By default, files are automatically opened for editing. To disable this feature, select Tools > Options > Version Control > Perforce, and then deselect the Automatically open files when editing check box.

To list files that are open for editing, select Tools > Perforce > Opened.

To group files for commit, select Tools > Perforce > Pending Changes.

To view information about changelists and the files in them, select Tools > Perforce > Describe.

By default, you are prompted to confirm that you want to submit changes. To suppress the prompt, select Tools > Options > Version Control > Perforce, and then deselect the Prompt on submit check box.

© 2017 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.