Importing Designs

"Artwork imported into Qt Design Studio"

You can import exported assets to a Qt Design Studio project and edit them in the Design mode.

Note: Attempting to import assets exported on another system might fail.

The following instructions use an empty project as an example. For more information about the options you have, see Creating UI Prototype Projects.

To import designs to Qt Design Studio projects:

  1. Select File > New File or Project > General > Choose, and follow the instructions of the wizard to create an empty project.
  2. In Projects, double-click Screen01.ui.qml to move to the Design mode.
  3. Select Library > Resources > Add New Resources.
  4. Select the folder where you exported the assets.
  5. Select Exported Assets (*.metadata) in the dropdown menu to filter .metadata files.
  6. Select a .metadata file to import, and then select Open.
  7. Select Details next to the QML/Asset Export Paths field to display the paths to copy the assets to.

    "Asset Import dialog"

  8. In the QML field, you can change the folder to copy the QML files to.
  9. In the Assets field, you can change the folder to copy the image files to.
  10. Select Import to import the QML files and assets. This might take a little while for complex projects.

The imported assets are displayed in the Resources tab in the Library as PNG images. The components that you specified in Adobe Photoshop are displayed in the My QML Components tab, as well as in the Project tab of the Navigator as separate QML files.

Note: The layer that was the bottom layer in Photoshop becames the top layer in the Navigator to reflect the QML code model. You can view the QML code in the Text Editor tab.

If asset importer conflicts, warnings, and errors are displayed in the Asset Import dialog while importing, fix the issues in Adobe Photoshop and export the assets again.

Qt Bridge Videos

For more information, watch a video tutorial and webinar about using Qt Bridge:

Available under certain Qt licenses.
Find out more.