Home · All Classes · All Functions · Overviews

[Platform Notes]

Platform Notes - X11

This page contains information about the X11 platforms Qt is currently known to run on, with links to platform-specific notes. More information about the combinations of platforms and compilers supported by Qt can be found on the Supported Platforms page.

AIX - 5.2

Qt has been tested on AIX 5.2, using the xlC compiler.

CompilerNotes
xlCIf Qt is built correctly but all symbols are reported to be missing when you link an application, your makeC++SharedLib script might be out of date. Make sure you have the latest version from the IBM website.
GCCWe have tested earlier versions of Qt 4 successfully with GCC version 3.3 and above. Some versions of GCC may fail to link Qt with a "TOC overflow" message. Fix this by upgrading to the latest maintenance release of the dynamic linker. On AIX this is bos.rte.bind_cmds.4.1.5.3 or later. Some versions of GCC may fail to build Qt with STL and large-file support enabled, due to a bug in GCC. Fix this by upgrading to the latest maintenance release of the compiler. It is also possible to work around this problem by running configure with either -no-stl or -no-largefile.

FreeBSD - 6.0-RELEASE

Note: FreeBSD is a community supported platform. See the Supported Platforms page for more information.

The system compiler on FreeBSD 4.x is gcc 2.95.4, which is not officially supported by Qt 4. We develop using and recommend ports/lang/gcc34. You will need to run configure with the -platform freebsd-g++34 arguments. Optionally, you may use ports/lang/icc.

The system compiler on FreeBSD 5.x and 6.x is GCC 3.4.4, which should be sufficient to build Qt. You do not need to add any special arguments when running configure. Optionally, you may use ports/lang/icc.

Note that we do not actively test FreeBSD 4.x and 5.x. Our developers migrated to 6.x after the Qt 4 launch. FreeBSD-CURRENT is not supported.

HP-UX

Qt supports HP-UX on both PA-RISC and the Itanium (IA64) architectures.

PA-RISC - B.11.11 or later

You can configure Qt for aCC in 32 and 64 bit mode (hpux-acc-64 or hpux-acc-32), or gcc in 32 bit mode (hpux-g++). The default platform is hpux-acc-32. The minimum required version for aCC (HP ANSI C++) on PA-RISC is A.03.57. The supported gcc compiler is gcc 3.4.3.

Itanium - B.11.23 or later

You can configure Qt for aCC in 32 and 64 bit mode (hpuxi-acc-64 or hpuxi-acc-32). gcc is currently unsupported. The default platform is hpuxi-acc-64. The minimum required version for aCC (HP ANSI C++) on Itanium is A.06.12.

OpenGL Support

Qt's OpenGL module requires GLX 1.3 or later to be installed. This is available for HP-UX 11i - see the Graphics and Technical Computing Software section of the release notes for more information.

IRIX - 6.5.x

IRIX is an unsupported platform - please see Qt's online Platform Support Policy for details.

Unpackaging and IRIX tar: Because of long filenames some files will be cut off incorrectly with IRIX tar. Please use GNU tar to unpack Qt packages.

Linux

There are no known problems with using Qt on production versions of Linux/x86, Linux/ppc, Linux/amd64 and Linux/ia64 (including Altix(R)).

For the gcc/g++ compiler, please also see the relevant compiler page.

Installation problems

See also the Installation FAQ.

If you experience problems when installing new open source versions of Qt versions, try to use the open source Qt archives (e.g., RPM) provided by your Linux distribution. If you need to install the source (.tgz) archive, be aware that you will probably end up with two different versions of the Qt library installed on your system, which will probably lead to link errors, like this:

 undefined reference to `_vt.11QPushButton'

Fix this by removing the old version of the library.

If you have problems installing open source versions of Qt provided by your Linux distribution (e.g., RPM), please consult the maintainers of the distribution, not us.

Some RPM versions have problems installing some of the Qt RPM archives where installation stops with an error message warning about a "Failed Dependency". Use the --nodeps option to rpm to workaround this problem.

Solaris - 9 or later

Unpackaging and Solaris tar

On some Solaris systems, both Solaris tar and GNU tar have been reported to truncate long filenames. We recommend using star instead (http://star.berlios.de).

CC on Solaris

Be sure to check our Forte Developer / Sun Studio notes.

GCC on Solaris

Be sure to check the installation notes for GCC on Solaris. Do not use GCC with Sun's assembler/linker, this will result in link-time errors in shared libraries. Use GNU binutils instead.

GCC 3.2.* is known to miscompile Qt due to an optimizer bug that will cause the resulting binaries to hang. Please use GCC 3.4.2 or later.

[Platform Notes]


Copyright © 2010 Nokia Corporation and/or its subsidiary(-ies) Trademarks
Qt 4.6.3