Qt Reference Documentation

Qt for Maemo 5 Requirements

Qt for Maemo 5 requires the official Scratchbox-based SDK. It can be downloaded from http://www.forum.nokia.com/Tools_Docs_and_Code/Tools/Platforms/Maemo/.

We recommend that you take a look at the Wiki found here: http://wiki.maemo.org/Documentation/Maemo5_Final_Installation.

The official Maemo 5 SDK contains the Qt binaries and tools required for development. Make sure the "libqt4-dev" package is installed for both the x86 and ARM targets within Scratchbox.

Running Qt applications on a real device requires the Qt 4 packages to be installed on your device. The Debian-based installation system will automatically fetch the required Qt libraries. See The Maemo 5 Platform - Introduction to Qt for more information about packaging Qt applications.

[Previous: General Qt Requirements]

X

Thank you for giving your feedback.

Make sure it is related to this specific page. For more general bugs and requests, please use the Qt Bug Tracker.

[0]; s.parentNode.insertBefore(ga, s); })();