Qt Reference Documentation

Qt for the Symbian platform Requirements

Qt for the Symbian platform requires the following software installed on your development PC:

  • Carbide.c++ v2.3.0 or higher recommended.
    • Note: It may be necessary to update the Carbide compiler depending on Carbide version. See here for instructions how to check your compiler version and how to patch it, if needed.
  • ActivePerl 5.6.1 build 638 or higher
    • Note: According to Symbian, version 5.6.1 build 638 is mandatory for building Symbian applications, but that version is no longer available from ActiveState. However, Qt for Symbian has been successfully compiled using both 5.8.x and 5.10.x versions.
  • S60 Platform SDK 3rd Edition FP1 or higher
    • Note: Users of S60 Platform SDK 3rd Edition FP1 also need special update. The update can be found here.
  • Open C/C++ v1.7.5 or higher. Install this to all Symbian SDKs you plan to use Qt with.
  • Building Qt tools from scratch requires MinGW 3.4.5 or higher, or another windows compiler.
    • Note: This is not required if you are using pre-built binary package.
  • Building Qt libraries requires RVCT version 2.2 (build 686 or later), which is not available free of charge. Usage of later versions of RVCT, including the 3.x and 4.x series, is not supported in this release.

Running Qt on real device requires the Open C to be installed on the device. The Open C installation packages are embedded into qt_installer.sis, which is included in Qt for Symbian binary package. If you are building Qt from scratch, you can find the required packages in the Symbian SDK where you installed Open C/C++:

  • nokia_plugin\openc\s60opencsis\pips_s60_<version>.sis
  • nokia_plugin\openc\s60opencsis\openc_ssl_s60_<version>.sis
  • nokia_plugin\opencpp\s60opencppsis\stdcpp_s60_<version>.sis

If you wish to do hardware debugging with Carbide or run applications in real devices using "make run" command, TRK must be installed to the device. Note: TRK is not required if you just want to install and run applications manually on the device.

  • Application TRK. Choose the correct installation package based on the S60 version of your device (S60_<S60-version>_app_trk_<TRK-version>.sisx).

We recommend you to take a look at Symbian Foundation - Qt Quick Start to get more information about how to setup the development environment.

See also Known Issues.

[Previous: General Qt Requirements]

X

Thank you for giving your feedback.

Make sure it is related to this specific page. For more general bugs and requests, please use the Qt Bug Tracker.

[0]; s.parentNode.insertBefore(ga, s); })();