C

Use the Qt Application Manager Project Wizard

The Qt Application Manager project wizard guides you step-by-step through the project creation process. The wizard prompts you to select the type of the project to create, as well as the location for it and the build tool used to build it. Via this wizard, you can create two types of projects: a System UI or an application that can be run under the System UI. For more details, see The Qt Application Manager.

Qt Application Manager Project Wizard

Create Qt Application Manager project by selecting the File > New File or Project > Other Project > Qt ApplicationManager Project > Choose.

In the Name field, enter a name for the new project. In the Create in field choose the root directory for the new project.

Select the type of the Qt Application Manager project (for more details see The Qt Application Manager). To choose System UI type, set the checkbox Use as System UI, otherwise keep it unset.

Select kits for the platforms to build the project for.

On the Summary page, you can observe files generated by the wizard.

Depending on the selected project file, you get a sample project of the System UI or an application that can be run under the System UI. To deploy and run applications see Deploy and Run Applications on Qt Application Manager Devices, as for the System UI - see Deploy and Run the System UI.

Available under certain Qt licenses.
Find out more.