Creating Qt Quick Effect Maker Files

Creating an Effect File

You can create empty Qt Quick Effect Maker effect (.qep) files in Qt Design Studio and then edit them in Qt Quick Effect Maker.

To create an effect file:

  1. In Qt Design Studio, go to File > New File.
  2. Go to the Effects tab and select Effect file (Effect Maker).

  3. Select Choose and follow the wizard to create the file.

After you have created the effect file, it is available in the Assets view.

Editing and Re-importing an Effect File

To edit an effect file in Qt Quick Effect Maker, double-click it in the Assets view. This opens the effect in Qt Quick Effect Maker where you can make your changes.

When you have edited the effect file in Qt Quick Effect Maker, you need to save and export it:

  1. In Qt Quick Effect Maker, go to File > Save.
  2. Select File > Export.
  3. With the default settings, select Ok.

Now, you can close Qt Quick Effect Maker and return to Qt Design Studio and apply the effect.

Applying an Effect

You can apply effects to components in Qt Design Studio. To do so, drag the effect from the Assets view to the component in the 2D view.

Animated Effect

When you import an animated effect, you need to turn on the animation for it to see the animation in your Qt Design Studio application.

To turn on animation for an effect, first apply the effect to a component, and then:

  1. Select the effect in Navigator.
  2. In Properties, go to the Exposed Custom Properties section and set timeRunning to true.

See also Working with Effects in Qt Quick Effect Maker.

Available under certain Qt licenses.
Find out more.