Setting Up an Autotools Project

The AutotoolsProjectManager is a plugin for autotools support. It is disabled by default. To enable the plugin, select Help > About Plugins > Build Systems > AutotoolsProjectManager.

To use the plugin, restart Qt Creator.

To work with your Autotools project in Qt Creator:

  1. Select File > Open File or Project.
  2. Select the file from your project. This is the only way you can use the autotools plugin.
  3. Select the build directory. Only in-source building is currently supported.
  4. Select Finish. Qt Creator displays the project tree structure. The root node displays the project name. All project files are listed below it and you can open them from the list.

  5. Select Run to build and run the application. The predefined build steps ( or autoreconf, configure, and make) are executed.

    The first time you run the application you must choose the executable.

  6. To check and edit autotools build steps, select Projects > Build Settings.

    You can add parameters to the predefined autotools build steps.

© 2016 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.