Qt Quick 3D Graphics Requirements

OpenGL Requirements

Qt Quick 3D requires OpenGL or OpenGL ES version 3.1 or newer.

OpenGL ES 2.0 support

Qt Quick 3D supports running on OpenGL ES 2.0, but with a limited feature set, depending on the driver and available extension. It's recommended that you evaluate the capabilities of your driver to find out which features will be available to you.

Known limitations running with OpenGL ES 2.0 are:

  • Shadow mapping
  • Image based lighting
  • Multi-sampling

© 2021 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.