Auf dieser Seite

Qt CoAP

Constrained Application Protocol (CoAP) ist ein Machine-to-Machine-Webübertragungsprotokoll (M2M) für den Einsatz mit ressourcenbeschränkten Knoten und Netzwerken im Internet der Dinge (IoT). Es ist so konzipiert, dass es sich problemlos mit HTTP verbinden lässt, um eine Integration ins Web zu ermöglichen, und erfüllt gleichzeitig spezielle Anforderungen wie Multicast-Unterstützung, sehr geringen Overhead und Einfachheit für ressourcenbeschränkte Umgebungen.

Das Modul „ Qt CoAP “ implementiert die Client-Seite von CoAP gemäß der Definition in RFC 7252. Im Allgemeinen ist CoAP für die Verwendung datagrammorientierter Transportprotokolle wie UDP ausgelegt, daher basiert die aktuelle Implementierung des Transports auf UDP. Die Implementierung benutzerdefinierter Transporte auf Basis von TCP, WebSocket usw. ist jedoch ebenfalls möglich.

Das Modul „ Qt CoAP “ unterstützt:

  • Sicherheit auf Basis von Datagram TLS (DTLS) über UDP
  • Gruppenkommunikation gemäß RFC 7390
  • Blockweise Übertragungen gemäß RFC 7959
  • Ressourcenbeobachtung gemäß RFC 7641
  • Ressourcenerkennung (Multicast und Einzel-Server)

Hinweis: Die Sicherheit ist optional: „ QCoapClient “ verwendet standardmäßig „ QtCoap::NoSecurity “ und muss im sicheren Modus konfiguriert werden, um DTLS zu aktivieren. Siehe „Sicherheit“.

Verwendung des Moduls

Die Verwendung eines Qt-Moduls erfordert die Verknüpfung mit der Modulbibliothek, entweder direkt oder über andere Abhängigkeiten. Mehrere Build-Tools bieten hierfür spezielle Unterstützung, darunter CMake und qmake.

Erstellen mit CMake

Verwenden Sie den Befehl „ find_package() “, um die benötigten Modulkomponenten im Paket „ Qt6 “ zu finden:

find_package(Qt6 REQUIRED COMPONENTS Coap)
target_link_libraries(mytarget PRIVATE Qt6::Coap)

Siehe auch die Übersicht „Erstellen mit CMake “.

Erstellen mit qmake

Um das Modul für die Erstellung mit qmake zu konfigurieren, fügen Sie das Modul als Wert der Variablen ` QT ` in die `.pro`-Datei des Projekts ein:

QT += coap

Artikel und Anleitungen

Beispiele

Referenz

Lizenzen und Namensnennungen

Qt CoAP ist unter kommerziellen Lizenzen von The Qt Company erhältlich. Darüber hinaus ist es unter der GNU General Public License, Version 3, verfügbar.

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.