Auf dieser Seite

SVG-Viewer

Ein Beispiel für „ Qt Widgets “ zum Rendern und Anzeigen von SVG-Dateien.

Screenshot des SVG-Viewer-Tools, das eine SVG-Datei anzeigt

Das Qt SVG Modul verwendet „ QPainter “ zum Rendern von SVG-Dateien, und dieses Beispiel veranschaulicht, wie man „ Qt Widgets “ zur Anzeige der gerenderten SVG-Dateien einsetzt. Der gesamte Zeichenbereich befindet sich innerhalb eines „ QScrollArea “. Auf diese Weise erscheinen automatisch zwei Bildlaufleisten, wenn der Benutzer ein SVG-Bild vergrößern möchte, um die Navigation zu erleichtern. Darüber hinaus besteht die Möglichkeit, die gerenderte SVG-Datei als gerastertes Bild zu exportieren.

Rendering

Um eine Datei zu öffnen, klicken Sie auf das Dateisymbol oder wählen Sie im Menü „Datei“ den Befehl „Öffnen“. Navigieren Sie anschließend durch das Dateisystem und wählen Sie eine SVG-Datei aus. Qt SVG verwendet einen Software-Renderer, um den Inhalt der Datei zu zeichnen. Dies sorgt für pixelgenaues Anti-Aliasing und eine Vielzahl von Funktionen. Bei komplexen SVG-Dateien kann dies jedoch eine erhebliche Belastung der CPU bedeuten. Verwenden Sie stattdessen „ VectorImage “, um einen hardwarebeschleunigten SVG-Renderer zu nutzen. Auf der Seite „2D-Grafiken in Qt“ finden Sie verschiedene Möglichkeiten, eine SVG-Datei in Qt zu laden.

Der SVG-Viewer verfügt über eine Schaltfläche „Aktualisieren“, um die aktuell geöffnete SVG-Datei neu zu laden. Die gleiche Schaltfläche ist auch im Menü „Ansicht“ verfügbar. Darüber hinaus gibt es im Menü „Ansicht“ die Option „Automatisch aktualisieren“, die den Viewer anweist, die Datei bei jeder Änderung automatisch neu zu rendern.

Der SVG-Viewer bietet drei verschiedene Hintergrundoptionen: „Weiß“, „Schwarz“ und „Kariert“. Diese Optionen können über die Symbole in der Symbolleiste oder über das Menü „Hintergrund“ aufgerufen werden. Darüber hinaus enthält dasselbe Menü eine Schaltfläche zum Aktivieren oder Deaktivieren des Umrisses um die gerenderte SVG-Datei.

Funktionen

Seit Qt 6.7 verfügt das Modul über zusätzliche Funktionen. Zuvor unterstützte das Modul lediglich SVG Tiny 1.2. Über das Menü „Funktionen“ können Sie diese neuen Funktionen aktivieren oder deaktivieren. So können Sie beispielsweise den Renderer auf den Funktionsumfang von SVG Tiny 1.2 beschränken oder Animationen vollständig deaktivieren. Eine vollständige Beschreibung dieser Funktionen finden Sie auf der Dokumentationsseite „ QtSvg::Option “.

Beispielprojekt @ code.qt.io

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.