Installing Platform Dependencies

Before building applications with Qt for INTEGRITY, install the correct build tools and other dependencies required in the 64-bit Linux development host:

RequirementDescription
INTEGRITY 19.0.13 installationThe installation must contain the patches for C++17 support. Contact Green Hills Software.

Note: GHS patches 14695, 16456, 16761, 16762 and 16917.

MULTI IDE and Green Hills Software Compiler (version 2020.1.4 or newer)The Green Hills Software development tools. See MULTI IDE. For licenses, contact Green Hills Software.

Note: GHS patches 16398 and 17423.

QC BSP [ES7] for GHS Integrity 19.0.13-QCThe development Qualcomm Board Support Package for Integrity and Snapdragon 8155P Board. Contact Green Hills Software.
QC [ES7] Customer packageAdditional patches and instructions from Qualcomm. Contact Qualcomm Support.
CMake 3.18.4 or higherCMake build system is now the default one for Qt 6 building. See CMake Documentation.
NinjaNinja is a build system with a focus on speed. It is used to build Google Chrome, parts of Android, LLVM, and can be used in many other projects due to CMake's Ninja backend. See Ninja.
Other extra packages (perl, python, etc) required to be installed Host OSSee Building Requirements.

Note: Perl is not required if you download the Qt sources via your Qt Account.

© 2021 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.