SVG 뷰어
SVG 파일을 렌더링하고 볼 수 있는 Qt Widgets 예제입니다.

이 Qt SVG 모듈은 QPainter 를 사용하여 SVG 파일을 렌더링하며, 이 예제는 Qt Widgets 를 사용하여 렌더링된 SVG 파일을 표시하는 방법을 보여줍니다. 전체 그리기 영역은 QScrollArea 내에 배치됩니다. 이렇게 하면 사용자가 SVG 이미지를 확대하고자 할 때, 탐색을 쉽게 할 수 있도록 두 개의 스크롤바가 자동으로 나타납니다. 또한, 렌더링된 SVG 파일을 래스터화 된 이미지로 내보내는 옵션도 있습니다.
렌더링
파일을 열려면 파일 아이콘을 클릭하거나 ‘파일’ 메뉴로 이동하여 ‘열기’를 클릭하십시오. 그런 다음 파일 시스템에서 SVG 파일을 선택하십시오. Qt SVG 는 소프트웨어 렌더러를 사용하여 파일의 내용을 그립니다. 이를 통해 픽셀 단위의 완벽한 앤티앨리어싱과 풍부한 기능을 제공합니다. 하지만 복잡한 SVG 파일의 경우 CPU에 상당한 처리 부하가 발생할 수 있습니다. 하드웨어 가속 SVG 렌더러를 사용하려면 대신 VectorImage 를 사용하십시오. Qt SVG 파일을 불러오는 다양한 방법에 대해서는 Qt의 2D 그래픽 페이지를 참조하십시오.
SVG 뷰어에는 현재 열려 있는 SVG 파일을 다시 불러오는 새로 고침 버튼이 있습니다. 이 버튼은 ‘보기(View)’ 메뉴에서도 사용할 수 있습니다. 또한, ‘보기’ 메뉴에는 파일이 수정될 때마다 뷰어가 자동으로 파일을 다시 렌더링하도록 하는 ‘자동 새로 고침(Auto Refresh )’ 옵션이 있습니다.
SVG 뷰어는 흰색, 검은색, 바둑판 무늬의 세 가지 배경 옵션을 제공합니다. 이러한 옵션은 도구 모음의 아이콘이나 ‘배경’ 메뉴를 통해 사용할 수 있습니다. 또한, 동일한 메뉴에는 렌더링된 SVG 파일 주변의 윤곽선을 표시하거나 숨길 수 있는 버튼이 있습니다.
기능
Qt 6.7부터 이 모듈에는 추가 기능이 도입되었습니다. 이전에는 이 모듈이 SVG Tiny 1.2만 지원했습니다. ‘기능(Features) ’ 메뉴를 통해 이러한 새로운 기능을 활성화하거나 비활성화할 수 있습니다. 예를 들어, 렌더러를 SVG Tiny 1.2 기능 세트로만 제한하거나 애니메이션을 완전히 비활성화할 수 있습니다. 이러한 기능에 대한 자세한 설명은 QtSvg::Option 문서 페이지를 참조하십시오.
© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.