本页内容

SVG 查看器

一个用于渲染和查看SVG文件的Qt Widgets 示例。

SVG查看器工具显示SVG文件的屏幕截图

该 Qt SVG 模块使用QPainter 渲染SVG文件,本示例演示了如何使用Qt Widgets 来显示渲染后的SVG文件。整个绘图区域位于QScrollArea 中。这样,当用户想要放大SVG图像时,会自动出现两个滚动条,以便于浏览。 此外,还提供了一项将渲染后的 SVG 文件导出为光栅化图像的选项。

渲染

要打开文件,请单击文件图标,或转到“文件”菜单并单击“打开”。然后,在文件系统中浏览并选择一个 SVG 文件。 Qt SVG 使用软件渲染器来绘制文件内容。这可提供像素级精准的抗锯齿效果以及丰富的功能集。但对于复杂的 SVG 文件,这可能会对 CPU 造成较大的处理负担。若需使用硬件加速的 SVG 渲染器,请改用 `VectorImage `。 请参阅Qt 中的 2D 图形页面,了解在 Qt 中加载 SVG 文件的不同方法。

SVG 查看器提供了一个“刷新”按钮,用于重新加载当前打开的 SVG 文件。该按钮也可通过“视图”菜单访问。此外,“视图”菜单中还有“自动刷新”选项,该选项可使查看器在文件发生修改时自动重新渲染文件。

SVG 查看器提供三种不同的背景选项:白色、黑色和棋盘格。可通过工具栏中的图标或“背景”菜单访问这些选项。此外,该菜单中还有一个按钮,用于启用或禁用渲染的 SVG 文件周围的轮廓线。

功能

自 Qt 6.7 起,该模块新增了多项功能。此前,该模块仅支持 SVG Tiny 1.2。通过“功能”菜单,您可以启用或禁用这些新功能。例如,您可以将渲染器限制为仅支持 SVG Tiny 1.2 功能集,或完全禁用动画效果。 有关这些功能的完整说明,请参阅QtSvg::Option 文档页面。

示例项目 @ code.qt.io

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.