Auf dieser Seite

Verwendung Qt Assistant

Screenshot von Qt Assistant mit Widgets für die Dokumentation

Sie können die Dokumentation im Dokumentationsfenster lesen. Um ein Thema in einem neuen Tab zu öffnen, klicken Sie mit der rechten Maustaste darauf im Inhaltsfenster, um ein Kontextmenü zu öffnen, und wählen Sie „Link in neuem Tab öffnen“. Alle geöffneten Themen werden im Fenster „Geöffnete Seiten “ aufgelistet. Wählen Sie ein Thema aus, um es im Dokumentationsfenster anzuzeigen.

Wenn Sie möchten, dass das Dokumentationsfenster so viel Platz wie möglich einnimmt, können Sie die Seitenleistenfenster ganz einfach gruppieren, verschieben oder ausblenden. Um die Fenster zu gruppieren, ziehen Sie eines auf das andere und lassen Sie die Maustaste los. Wenn ein oder alle Seitenleistenfenster nicht angezeigt werden, verwenden Sie Tastenkombinationen, um sie einzublenden. Die Tastenkombinationen finden Sie im Menü „Ansicht “.

Die Seitenleistenfenster lassen sich im Hauptfenster andocken, sodass Sie sie an den oberen, linken, rechten oder unteren Rand des Hauptfensters ziehen können. Alternativ können Sie sie aus „ Qt Assistant “ herausziehen, um sie als eigenständige Fenster anzuzeigen.

Um die Schriftart und die Schriftgröße des Browserfensters, in dem die Dokumentation angezeigt wird, oder der Anwendung selbst zu ändern, wählen Sie „Bearbeiten“ > „Einstellungen“ > „Schriftarten“.

Screenshot, der das Einstellungsmenü des Qt Assistant zur Änderung der Schriftarteneinstellungen zeigt

Um die Schriftgröße im Dokumentationsfenster vorübergehend zu vergrößern oder zu verkleinern, wählen Sie „Ansicht“ > „Vergrößern“ oder „Verkleinern“. Um die Schriftgröße zurückzusetzen, wählen Sie „Ansicht“ > „Normale Größe“.

Um zwischen den Seiten zu navigieren, wählen Sie „Gehe zu“ > „Zurück“ oder „Weiter“. Dadurch gelangen Sie zur vorherigen bzw. nächsten Seite im Verlauf. Um zur Startseite zurückzukehren, wählen Sie „Gehe zu“ > „Startseite“. Um die Startseite festzulegen, wählen Sie „Bearbeiten“ > „Einstellungen“ > „Optionen“.

Um das Inhaltsverzeichnis -Fenster mit der aktuell im Dokumentationsfenster angezeigten Seite zu synchronisieren, wählen Sie „Gehe zu“ > „Mit Inhaltsverzeichnis synchronisieren“.

Die Adressleiste bietet eine schnelle Möglichkeit, eine bestimmte URL für eine Dokumentationsdatei einzugeben. Um die Adressleiste anzuzeigen, wählen Sie „Ansicht“ > „Symbolleisten“ > „Adressleiste“.

Suche im Seiteninhalt

Um Text auf der aktuellen Seite zu finden, wählen Sie „Bearbeiten“ > „Im Text suchen“. Geben Sie den Suchbegriff in das Feld ein. Die Suche erfolgt inkrementell, d. h., das relevanteste Ergebnis wird bereits angezeigt, während Sie Zeichen in das Feld eingeben.

Wenn Sie das Kontrollkästchen „Groß-/Kleinschreibung beachten“ aktivieren, berücksichtigt die Suche die Groß- und Kleinschreibung des Suchbegriffs. Wenn Sie beispielsweise nach „spin“ suchen, wird „spin“ gefunden, nicht jedoch „Spin“.

Um von Ihrer aktuellen Position auf der Seite aus vorwärts oder rückwärts zu suchen, klicken Sie auf „Zurück “ oder „Weiter“.

Um das Suchfeld auszublenden, klicken Sie entweder auf „Schließen“ oder drücken Sie die Esc-Taste.

Volltextsuche

Screenshot des Suchmenüs im <span translate=Qt Assistant zum Durchsuchen der Dokumentation" src="images/assistant-search.png" title="Screenshot des Suchmenüs im Qt Assistant zum Durchsuchen der Dokumentation"/>

Qt Assistant bietet eine leistungsstarke Volltextsuchmaschine. Sie können im Suchfenster nach bestimmten Wörtern oder Textstellen suchen. Geben Sie den gesuchten Text ein und drücken Sie die Eingabetaste oder klicken Sie auf „Suchen“. Bei der Suche wird die Groß-/Kleinschreibung nicht berücksichtigt. Beispielsweise werden „Foo“, „fOo“ und „FOO“ alle als identisch behandelt.

Mit der FTS-Abfragesyntax können Sie komplexe Abfragen erstellen.

Im Folgenden finden Sie Beispiele für gängige Suchmuster:

  • deep – listet alle Dokumente auf, die das Wort „deep“ enthalten
  • deep* – listet alle Dokumente auf, die ein Wort enthalten, das mit „deep“ beginnt
  • deep copy – listet alle Dokumente auf, die sowohl „deep“ als auch „copy“ enthalten
  • "deep copy" – listet alle Dokumente auf, die die Wortgruppe „deep copy“ enthalten

Die Liste der gefundenen Dokumente ist nach der Anzahl der Vorkommen des Suchtextes sortiert, wobei diejenigen mit der höchsten Anzahl an Vorkommen an erster Stelle stehen. Klicken Sie einfach auf ein beliebiges Dokument in der Liste, um es im Dokumentationsfenster anzuzeigen.

Wenn sich die Dokumentation geändert hat – beispielsweise wenn Dokumente hinzugefügt oder entfernt wurden –, indexiert „ Qt Assistant “ diese erneut.

Filtern von Hilfeinhalten

Qt Assistant ermöglicht es Ihnen, jede Art von Dokumentation zu installieren, solange diese in komprimierten Qt-Hilfedateien (*.qch) organisiert ist. So können Sie beispielsweise die Qt-Referenzdokumentation für mehrere Qt-Versionen gleichzeitig anzeigen. In vielerlei Hinsicht ist dies sehr praktisch, da nur eine Version von „ Qt Assistant “ benötigt wird. Gleichzeitig wird es jedoch komplizierter, wenn Aufgaben wie die Suche im Index durchgeführt werden, da die meisten Schlüsselwörter in mehr als einer Qt-Version definiert sind. Das bedeutet, dass „ Qt Assistant “ den Benutzer immer auffordert, auszuwählen, welche Version angezeigt werden soll.

Wir verwenden Dokumentationsfilter, um dieses Problem zu lösen. Ein Filter wird durch seinen Namen identifiziert und enthält eine Liste von Filterattributen. Ein Attribut ist lediglich eine Zeichenkette und kann frei gewählt werden. Attribute werden durch die Dokumentation selbst definiert, was bedeutet, dass jeder Dokumentationssatz in der Regel über ein oder mehrere Attribute verfügt.

Beispielsweise definiert die Dokumentation zu „ Qt Assistant “ die Attribute „ assistant “ und „ tools “, während „ Qt Widgets Designer“ die Attribute „ designer “ und „ tools “ definiert. Der Filter zur Anzeige aller Tools würde dann nur das Attribut „ tools “ definieren, da dieses Attribut Teil beider Dokumentationssätze ist. Würde man das Attribut „ assistant “ zum Filter hinzufügen, würde nur die Dokumentation unter Qt Assistant angezeigt werden, da die Dokumentation zu „ Qt Widgets Designer“ dieses Attribut nicht enthält. Eine leere Liste von Attributen in einem Filter führt dazu, dass alle Dokumentationen angezeigt werden. Das entspricht also der Abfrage ungefilterter Dokumentation.

Um Dokumentationsfilter zu erstellen und zu entfernen, wählen Sie „Bearbeiten“ > „Einstellungen “ > „Filter“.

Screenshot, der das Einstellungsmenü des Qt Assistant zeigt, mit dem sich filtern lässt, welche Kategorien angezeigt werden sollen

Um einen neuen Filter hinzuzufügen, klicken Sie auf „Hinzufügen“, geben Sie einen Filternamen an und klicken Sie auf „OK“. Wählen Sie anschließend die Filterattribute im Feld „Attribute “ aus.

Um einen Filter zu löschen, wählen Sie ihn aus und klicken Sie auf „Entfernen“.

Über die Filter-Symbolleiste können Sie einen Filter auf die aktuell installierte Dokumentation anwenden. Um die Filter-Symbolleiste anzuzeigen, wählen Sie „Ansicht“ > „Symbolleisten“ > „Filter-Symbolleiste“.

Dokumentation hinzufügen

Um komprimierte Hilfedateien zu installieren und zu entfernen, wählen Sie „Bearbeiten“ > „Einstellungen “ > „Dokumentation“.

Screenshot, der das Einstellungsmenü des Qt Assistant zum Hinzufügen oder Entfernen von Einträgen aus der Dokumentationsliste zeigt

Klicken Sie auf die Schaltfläche „Installieren“ und wählen Sie den Pfad der komprimierten Hilfedatei (*.qch) aus, die Sie installieren möchten. Um eine Hilfedatei zu löschen, wählen Sie einen Dokumentationssatz in der Liste aus und klicken Sie auf „Entfernen“.

Hinweis: Die komprimierten Qt Help-Dateien (.qch) sollten nur aus vertrauenswürdigen Quellen geladen werden.

Festlegen der Startseite

Um die Startseite festzulegen, die Qt Assistant anzeigt, wenn Sie auf die Schaltfläche „Startseite“ klicken, wählen Sie „Bearbeiten“ > „Einstellungen “ > „Optionen“.

Geben Sie die URL der Startseite ein oder wählen Sie „Aktuelle Seite“, um die aktuell angezeigte Seite als Startseite festzulegen. Um die Startseite leer zu lassen, wählen Sie „Leere Seite“. Wählen Sie „Auf Standard zurücksetzen“, um Ihre Startseite auf die Standard-Startseite zurückzusetzen.

Verwendung von Befehlszeilenoptionen

Qt Assistant unterstützt die folgenden Befehlszeilenoptionen:

BefehlszeilenoptionKurzbeschreibung
-collectionFile <Datei.qhc>Verwendet die angegebene Sammlungsdatei anstelle der Standarddatei.
-showUrl <URL>Zeigt das Dokument an, auf das die URL verweist.
-enableRemoteControlAktiviert die Fernsteuerung von „ Qt Assistant “.
-show <Widget>Zeigt das angegebene Seitenleistenfenster an, das „Inhalt“, „Index“, „Lesezeichen“ oder „Suche“ sein kann.
-hide <Widget>Blendet das angegebene Seitenleistenfenster aus, das „Inhalt“, „Index“, „Lesezeichen“ oder „Suche“ sein kann.
-activate <Widget>Aktiviert das angegebene Seitenleistenfenster, das „Inhalt“, „Index“, „Lesezeichen“ oder „Suche“ sein kann.
-register <doc.qch>Registriert die angegebene komprimierte Hilfedatei in der angegebenen Hilfesammlung.
-unregister <doc.qch>Hebt die Registrierung der angegebenen komprimierten Hilfedatei in der angegebenen Sammlungsdatei auf.
-remove-search-indexLöscht den Index der Hilfe-Suchmaschine. Diese Option ist nützlich, falls die zugehörigen Indexdateien beschädigt sind. „ Qt Assistant “ indiziert die Dokumentation beim nächsten Start neu.
-rebuild-search-indexErstellt den Index der Hilfe-Suchmaschine neu. Beachten Sie, dass dieser Vorgang eine Weile dauern kann.
-setCurrentFilter <Filter>Legt den angegebenen Filter als aktiven Filter fest.
-quietZeigt keine Fehler-, Warn- oder Erfolgsmeldungen an.

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.