Auf dieser Seite

QHostAddress Class

Die Klasse „QHostAddress“ stellt eine IP-Adresse bereit. Mehr...

Header: #include <QHostAddress>
CMake: find_package(Qt6 REQUIRED COMPONENTS Network)
target_link_libraries(mytarget PRIVATE Qt6::Network)
qmake: QT += network

Öffentliche Typen

flags ConversionMode
enum ConversionModeFlag { StrictConversion, ConvertV4MappedToIPv4, ConvertV4CompatToIPv4, ConvertLocalHost, ConvertUnspecifiedAddress, TolerantConversion }
enum SpecialAddress { Null, LocalHost, LocalHostIPv6, Broadcast, AnyIPv4, …, Any }

Öffentliche Funktionen

QHostAddress()
QHostAddress(QHostAddress::SpecialAddress address)
QHostAddress(const QString &address)
QHostAddress(const Q_IPV6ADDR &ip6Addr)
QHostAddress(const quint8 *ip6Addr)
QHostAddress(const sockaddr *sockaddr)
QHostAddress(quint32 ip4Addr)
QHostAddress(const QHostAddress &address)
(since 6.8) QHostAddress(QHostAddress &&other)
~QHostAddress()
void clear()
bool isBroadcast() const
bool isEqual(const QHostAddress &other, QHostAddress::ConversionMode mode = TolerantConversion) const
bool isGlobal() const
bool isInSubnet(const QHostAddress &subnet, int netmask) const
bool isInSubnet(const std::pair<QHostAddress, int> &subnet) const
bool isLinkLocal() const
bool isLoopback() const
bool isMulticast() const
bool isNull() const
(since 6.6) bool isPrivateUse() const
bool isSiteLocal() const
bool isUniqueLocalUnicast() const
int protocol() const
QString scopeId() const
void setAddress(quint32 ip4Addr)
void setAddress(QHostAddress::SpecialAddress address)
bool setAddress(const QString &address)
void setAddress(const Q_IPV6ADDR &ip6Addr)
void setAddress(const quint8 *ip6Addr)
void setAddress(const sockaddr *sockaddr)
void setScopeId(const QString &id)
void swap(QHostAddress &other)
quint32 toIPv4Address(bool *ok = nullptr) const
Q_IPV6ADDR toIPv6Address() const
QString toString() const
bool operator!=(QHostAddress::SpecialAddress other) const
bool operator!=(const QHostAddress &other) const
QHostAddress &operator=(QHostAddress::SpecialAddress address)
QHostAddress &operator=(const QHostAddress &address)
bool operator==(QHostAddress::SpecialAddress other) const
bool operator==(const QHostAddress &other) const

Statische öffentliche Mitglieder

std::pair<QHostAddress, int> parseSubnet(const QString &subnet)
size_t qHash(const QHostAddress &key, size_t seed = 0)
bool operator!=(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)
QDataStream &operator<<(QDataStream &out, const QHostAddress &address)
bool operator==(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)
QDataStream &operator>>(QDataStream &in, QHostAddress &address)

Ausführliche Beschreibung

Diese Klasse enthält eine IPv4- oder IPv6-Adresse auf plattform- und protokollunabhängige Weise.

QHostAddress wird normalerweise zusammen mit den Methoden „ QTcpSocket “, „ QTcpServer “ und „ QUdpSocket “ verwendet, um eine Verbindung zu einem Host herzustellen oder einen Server einzurichten.

Eine Host-Adresse wird mit ` setAddress()` gesetzt und mit ` toIPv4Address()`, ` toIPv6Address()` oder ` toString()` abgerufen. Den Typ können Sie mit ` protocol()` überprüfen.

Hinweis: Bitte beachten Sie, dass QHostAddress keine DNS-Abfragen durchführt. Hierfür wird QHostInfo benötigt.

Die Klasse unterstützt außerdem gängige vordefinierte Adressen: Null, LocalHost, LocalHostIPv6, Broadcast und Any.

Siehe auch QHostInfo, QTcpSocket, QTcpServer und QUdpSocket.

Dokumentation zu Mitgliedstypen

enum QHostAddress::ConversionModeFlag
flags QHostAddress::ConversionMode

KonstanteWertBeschreibung
QHostAddress::StrictConversion0IPv6-Adressen werden beim Vergleich zweier „ QHostAddress “-Objekte unterschiedlicher Protokolle nicht in IPv4 konvertiert, sodass sie stets als unterschiedlich betrachtet werden.
QHostAddress::ConvertV4MappedToIPv41IPv6-Adressen, die auf IPv4 abgebildet sind (RFC 4291, Abschnitt 2.5.5.2), werden beim Vergleich konvertiert. Daher werden „ QHostAddress “ („::ffff:192.168.1.1“) und „ QHostAddress “ („192.168.1.1“) als gleich angesehen.
QHostAddress::ConvertV4CompatToIPv42Konvertiere IPv4-kompatible IPv6-Adressen (RFC 4291, Abschnitt 2.5.5.1) beim Vergleich. Daher wird QHostAddress(„::192.168.1.1“) als gleichwertig mit QHostAddress(„192.168.1.1“) verglichen.
QHostAddress::ConvertLocalHost8Konvertieren Sie die IPv6-Loopback-Adressen beim Vergleich in ihr IPv4-Äquivalent. Daher wird z. B. QHostAddress(„::1“) als gleichwertig mit QHostAddress(„127.0.0.1“) verglichen.
QHostAddress::ConvertUnspecifiedAddress4Alle nicht näher bezeichneten Adressen werden als gleichwertig verglichen, nämlich AnyIPv4, AnyIPv6 und „Any“.
QHostAddress::TolerantConversion0xffSetzt alle drei vorangehenden Flags.

Der Typ „ConversionMode“ ist ein `typedef` für `QFlags<ConversionModeFlag>`. Er speichert eine ODER-Kombination von `ConversionModeFlag`-Werten.

Siehe auch isEqual().

enum QHostAddress::SpecialAddress

KonstanteWertBeschreibung
QHostAddress::Null0Das Null-Adressobjekt. Entspricht QHostAddress(). Siehe auch QHostAddress::isNull().
QHostAddress::LocalHost2Die IPv4-Localhost-Adresse. Entspricht QHostAddress(„127.0.0.1“).
QHostAddress::LocalHostIPv63Die IPv6-Localhost-Adresse. Entspricht QHostAddress(„::1“).
QHostAddress::Broadcast1Die IPv4-Broadcast-Adresse. Entspricht QHostAddress(„255.255.255.255“).
QHostAddress::AnyIPv46Die IPv4-Any-Adresse. Entspricht QHostAddress(„0.0.0.0“). Ein mit dieser Adresse gebundener Socket lauscht ausschließlich auf IPv4-Schnittstellen.
QHostAddress::AnyIPv65Die IPv6-Any-Adresse. Entspricht QHostAddress(„::“). Ein mit dieser Adresse gebundener Socket hört nur auf IPv6-Schnittstellen.
QHostAddress::Any4Die Dual-Stack-Any-Adresse. Ein mit dieser Adresse gebundener Socket lauscht sowohl auf IPv4- als auch auf IPv6-Schnittstellen.

Dokumentation der Mitgliedsfunktionen

QHostAddress::QHostAddress()

Erstellt ein Objekt mit einer Null-Host-Adresse, d. h. eine Adresse, die für keinen Host und keine Schnittstelle gültig ist.

Siehe auch „ clear()“.

QHostAddress::QHostAddress(QHostAddress::SpecialAddress address)

Erstellt ein QHostAddress-Objekt für address.

[explicit] QHostAddress::QHostAddress(const QString &address)

Erstellt eine IPv4- oder IPv6-Adresse auf der Grundlage der Zeichenfolge „ address “ (z. B. „127.0.0.1“).

Siehe auch setAddress().

[explicit] QHostAddress::QHostAddress(const Q_IPV6ADDR &ip6Addr)

Erstellt ein Hostadressobjekt mit der IPv6-Adresse ip6Addr.

[explicit] QHostAddress::QHostAddress(const quint8 *ip6Addr)

Erstellt ein Hostadressobjekt mit der IPv6-Adresse ip6Addr.

ip6Addr Muss ein 16-Byte-Array in Netzwerk-Byte-Reihenfolge (Big-Endian) sein.

[explicit] QHostAddress::QHostAddress(const sockaddr *sockaddr)

Erstellt eine IPv4- oder IPv6-Adresse unter Verwendung der durch die native Struktur „ sockaddr “ angegebenen Adresse.

Siehe auch setAddress().

[explicit] QHostAddress::QHostAddress(quint32 ip4Addr)

Erstellt ein Hostadressobjekt mit der IPv4-Adresse ip4Addr.

QHostAddress::QHostAddress(const QHostAddress &address)

Erstellt eine Kopie des angegebenen „ address “.

[constexpr noexcept default, since 6.8] QHostAddress::QHostAddress(QHostAddress &&other)

Erstellt eine neue `QHostAddress` aus ` other`.

Hinweis: Das Objekt „ other “, aus dem die Zuweisung erfolgt, befindet sich in einem teilweise initialisierten Zustand, in dem nur die Zerstörung und die Zuweisung eines neuen Werts zulässig sind.

Diese Funktion wurde in Qt 6.8 eingeführt.

[noexcept] QHostAddress::~QHostAddress()

Löscht das Host-Adressobjekt.

void QHostAddress::clear()

Setzt die Host-Adresse auf null und das Protokoll auf „ QAbstractSocket::UnknownNetworkLayerProtocol “.

Siehe auch „ QHostAddress::Null “.

bool QHostAddress::isBroadcast() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um die IPv4-Broadcast-Adresse handelt, andernfalls „ false “. Die IPv4-Broadcast-Adresse lautet 255.255.255.255.

Beachten Sie, dass diese Funktion für die lokale Broadcast-Adresse eines IPv4-Netzwerks nicht „true“ zurückgibt. Verwenden Sie hierfür bitte „ QNetworkInterface “, um die Broadcast-Adressen des lokalen Rechners zu ermitteln.

Siehe auch isLoopback(), isGlobal(), isMulticast(), isLinkLocal(), isUniqueLocalUnicast() und isPrivateUse().

bool QHostAddress::isEqual(const QHostAddress &other, QHostAddress::ConversionMode mode = TolerantConversion) const

Gibt „ true “ zurück, wenn diese Hostadresse mit der angegebenen „ other “-Adresse übereinstimmt; andernfalls wird „ false “ zurückgegeben.

Der Parameter „ mode “ steuert, welche Umwandlungen zwischen Adressen unterschiedlicher Protokolle durchgeführt werden. Wenn kein „ mode “ angegeben ist, wird standardmäßig „ TolerantConversion “ verwendet.

Siehe auch ` ConversionMode ` und ` operator==()`.

bool QHostAddress::isGlobal() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um eine globale IPv4- oder IPv6-Adresse handelt, andernfalls „ false “. Eine globale Adresse ist eine Adresse, die nicht für spezielle Zwecke (wie Loopback oder Multicast) oder zukünftige Zwecke reserviert ist.

Beachten Sie, dass eindeutige lokale IPv6-Unicast-Adressen als globale Adressen gelten (siehe isUniqueLocalUnicast()), ebenso wie IPv4-Adressen, die gemäß RFC 1918 für lokale Netzwerke reserviert sind.

Beachten Sie außerdem, dass IPv6-Site-Local-Adressen veraltet sind und in neuen Anwendungen als global betrachtet werden sollten. Diese Funktion gibt auch für Site-Local-Adressen „true“ zurück.

Siehe auch isLoopback(), isSiteLocal(), isUniqueLocalUnicast() und isPrivateUse().

bool QHostAddress::isInSubnet(const QHostAddress &subnet, int netmask) const

Gibt „ true “ zurück, wenn sich diese IP-Adresse in dem Subnetz befindet, das durch das Netzwerkpräfix „ subnet “ und die Netzmaske „ netmask “ beschrieben wird.

Der Parameter „ netmask “ ist die Präfixlänge – die Anzahl der führenden Bits, die zur Identifizierung des Netzwerkteils der Adresse verwendet werden. Bei IPv4 liegen die gültigen Werte zwischen 0 und 32, bei IPv6 zwischen 0 und 128.

Eine IP-Adresse gilt als zu einem Subnetz gehörend, wenn sie zwischen der niedrigsten und der höchsten Adresse in diesem Subnetz liegt. Bei IP Version 4 ist die niedrigste Adresse die Netzwerkadresse, während die höchste Adresse die Broadcast-Adresse ist.

Das Argument „ subnet “ muss nicht unbedingt die tatsächliche Netzwerkadresse (die niedrigste Adresse im Subnetz) sein. Es kann sich um jede gültige IP-Adresse handeln, die zu diesem Subnetz gehört. Insbesondere wenn es mit der von diesem Objekt gehaltenen IP-Adresse übereinstimmt, gibt diese Funktion immer „true“ zurück (vorausgesetzt, die Präfixlänge ist ein gültiger Wert).

Siehe auch parseSubnet().

bool QHostAddress::isInSubnet(const std::pair<QHostAddress, int> &subnet) const

Gibt „ true “ zurück, wenn sich diese IP-Adresse in dem durch „ subnet “ beschriebenen Subnetz befindet. Das Element „ QHostAddress “ von „ subnet “ enthält das Netzwerkpräfix, und das Element „int“ (zweites Element) enthält die Netzmaske (Präfixlänge).

Dies ist eine überladene Funktion.

bool QHostAddress::isLinkLocal() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um eine IPv4- oder IPv6-Link-Local-Adresse handelt, andernfalls „ false “.

Eine IPv4-Link-Local-Adresse ist eine Adresse im Netzwerk 169.254.0.0/16. Eine IPv6-Link-Local-Adresse ist eine Adresse im Netzwerk fe80::/10. Weitere Informationen finden Sie im IANA-Register für IPv6-Adressräume.

Siehe auch isLoopback(), isGlobal(), isMulticast(), isSiteLocal(), isUniqueLocalUnicast() und isPrivateUse().

bool QHostAddress::isLoopback() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um die IPv6-Loopback-Adresse oder eine der IPv4-Loopback-Adressen handelt.

bool QHostAddress::isMulticast() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um eine IPv4- oder IPv6-Multicast-Adresse handelt, andernfalls „ false “.

Siehe auch isLoopback(), isGlobal(), isLinkLocal(), isSiteLocal(), isUniqueLocalUnicast() und isPrivateUse().

bool QHostAddress::isNull() const

Gibt „ true “ zurück, wenn diese Hostadresse für keinen Host und keine Schnittstelle gültig ist.

Der Standardkonstruktor erstellt eine Nulladresse.

Siehe auch ` QHostAddress::Null`.

[since 6.6] bool QHostAddress::isPrivateUse() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um eine eindeutige lokale IPv6-Unicast-Adresse oder eine gemäß RFC 1918 für lokale Netzwerke reservierte IPv4-Adresse handelt, andernfalls „ false “.

Diese Funktion wurde in Qt 6.6 eingeführt.

Siehe auch isLoopback(), isGlobal(), isMulticast(), isLinkLocal(), isUniqueLocalUnicast() und isBroadcast().

bool QHostAddress::isSiteLocal() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um eine IPv6-Site-Local-Adresse handelt, andernfalls „ false “.

Eine IPv6-Standortadresse ist eine Adresse im Netzwerk fec0::/10. Weitere Informationen finden Sie im IANA -Register für IPv6-Adressräume.

IPv6-Standortlokale Adressen sind veraltet und sollten in neuen Anwendungen nicht mehr verwendet werden. Neue Anwendungen sollten sich nicht auf diese Funktion verlassen und standortlokale Adressen wie globale Adressen behandeln (weshalb isGlobal() ebenfalls „true“ zurückgibt). Standortlokale Adressen wurden durch Unique Local Addresses (ULA) ersetzt.

Siehe auch isLoopback(), isGlobal(), isMulticast(), isLinkLocal(), isUniqueLocalUnicast() und isPrivateUse().

bool QHostAddress::isUniqueLocalUnicast() const

Gibt „ true “ zurück, wenn es sich bei der Adresse um eine eindeutige lokale IPv6-Unicast-Adresse handelt, andernfalls „ false “.

Eine eindeutige lokale IPv6-Unicast-Adresse ist eine Adresse im Netzwerk fc00::/7. Weitere Informationen finden Sie im IANA -Register für IPv6-Adressräume.

Beachten Sie, dass eindeutige lokale Unicast-Adressen ebenfalls als globale Adressen gelten. RFC 4193 besagt, dass „Anwendungen diese Adressen in der Praxis wie Adressen mit globalem Geltungsbereich behandeln dürfen“. Nur Router müssen auf diese Unterscheidung achten.

Siehe auch isLoopback(), isGlobal(), isMulticast(), isLinkLocal() und isPrivateUse().

[static] std::pair<QHostAddress, int> QHostAddress::parseSubnet(const QString &subnet)

Analysiert die in subnet enthaltenen IP- und Subnetz-Informationen und gibt das Netzwerkpräfix für dieses Netzwerk sowie dessen Präfixlänge zurück.

Die IP-Adresse und die Netzmaske müssen durch einen Schrägstrich (/) getrennt sein.

Diese Funktion unterstützt Argumente in der Form:

  • 123.123.123.123/n, wobei n ein beliebiger Wert zwischen 0 und 32 ist
  • 123.123.123.123/255.255.255.255
  • <ipv6-Adresse>/n, wobei n ein beliebiger Wert zwischen 0 und 128 ist

Bei IP Version 4 akzeptiert diese Funktion auch fehlende abschließende Komponenten (d. h. weniger als 4 Oktette, wie z. B. „192.168.1“), unabhängig davon, ob ein Punkt folgt oder nicht. Fehlt in diesem Fall auch die Netzmaske, wird sie auf die Anzahl der tatsächlich übergebenen Oktette gesetzt (im obigen Beispiel wären das 24, da 3 Oktette vorhanden sind).

Siehe auch isInSubnet().

int QHostAddress::protocol() const

Gibt das Protokoll der Netzwerkschicht der Host-Adresse zurück.

QString QHostAddress::scopeId() const

Gibt die Scope-ID einer IPv6-Adresse zurück. Bei IPv4-Adressen oder wenn die Adresse keine Scope-ID enthält, wird eine leere „ QString “ zurückgegeben.

Die IPv6-Scope-ID legt den Erreichbarkeitsbereich für nicht-globale IPv6-Adressen fest und schränkt damit den Bereich ein, in dem die Adresse verwendet werden kann. Alle IPv6-Adressen sind mit einem solchen Erreichbarkeitsbereich verknüpft. Die Scope-ID dient dazu, Adressen zu unterscheiden, deren globale Eindeutigkeit nicht garantiert ist.

IPv6 definiert die folgenden vier Erreichbarkeitsstufen:

  • Knotenlokal: Adressen, die ausschließlich für die Kommunikation mit Diensten auf derselben Schnittstelle verwendet werden (z. B. die Loopback-Schnittstelle „::1“).
  • Link-lokal: Adressen, die lokal auf die Netzwerkschnittstelle (Link) beschränkt sind. Für jede IPv6-Schnittstelle auf Ihrem Host gibt es immer eine link-lokale Adresse. Link-lokale Adressen („fe80...“) werden aus der MAC-Adresse des lokalen Netzwerkadapters generiert und sind nicht garantiert eindeutig.
  • Global: Für global routbare Adressen, wie z. B. öffentliche Server im Internet.

Bei der Verwendung einer Link-Local- oder Site-Local-Adresse für IPv6-Verbindungen müssen Sie die Scope-ID angeben. Die Scope-ID für eine Link-Local-Adresse entspricht in der Regel dem Schnittstellennamen (z. B. „eth0“, „en1“) oder der Nummer (z. B. „1“, „2“).

Siehe auch setScopeId(), QNetworkInterface und QNetworkInterface::interfaceFromName.

void QHostAddress::setAddress(quint32 ip4Addr)

Legen Sie die unter „ ip4Addr “ angegebene IPv4-Adresse fest.

void QHostAddress::setAddress(QHostAddress::SpecialAddress address)

Setzt die durch ` address` angegebene spezielle Adresse.

Dies ist eine überladene Funktion.

bool QHostAddress::setAddress(const QString &address)

Setzt die IPv4- oder IPv6-Adresse, die durch die in „ address “ angegebene Zeichenfolgendarstellung definiert ist (z. B. „127.0.0.1“). Gibt „ true “ zurück und setzt die Adresse, wenn die Adresse erfolgreich geparst wurde; andernfalls wird „ false “ zurückgegeben.

Dies ist eine überladene Funktion.

void QHostAddress::setAddress(const Q_IPV6ADDR &ip6Addr)

Die unter ip6Addr angegebene IPv6-Adresse festlegen.

Dies ist eine überladene Funktion.

void QHostAddress::setAddress(const quint8 *ip6Addr)

Legen Sie die unter ip6Addr angegebene IPv6-Adresse fest.

ip6Addr muss ein Array aus 16 Bytes in Netzwerk-Byte-Reihenfolge sein (höchstwertiges Byte zuerst).

Dies ist eine überladene Funktion.

void QHostAddress::setAddress(const sockaddr *sockaddr)

Setzt die durch die native Struktur „ sockaddr “ angegebene IPv4- oder IPv6-Adresse. Gibt „ true “ zurück und setzt die Adresse, wenn die Adresse erfolgreich geparst wurde; andernfalls wird „ false “ zurückgegeben.

Dies ist eine überladene Funktion.

void QHostAddress::setScopeId(const QString &id)

Setzt die IPv6-Scope-ID der Adresse auf „ id “. Wenn das Adressprotokoll nicht IPv6 ist, hat diese Funktion keine Auswirkung. Die Scope-ID kann als Schnittstellenname (z. B. „eth0“ oder „en1“) oder als Ganzzahl, die den Schnittstellenindex angibt, festgelegt werden. Wenn id ein Schnittstellenname ist, wandelt QtNetwork diesen vor dem Aufruf der Netzwerkfunktionen des Betriebssystems mithilfe von QNetworkInterface::interfaceIndexFromName() in einen Schnittstellenindex um.

Siehe auch scopeId(), QNetworkInterface und QNetworkInterface::interfaceFromName.

[noexcept] void QHostAddress::swap(QHostAddress &other)

Tauscht diese Host-Adresse gegen other aus. Dieser Vorgang ist sehr schnell und schlägt niemals fehl.

quint32 QHostAddress::toIPv4Address(bool *ok = nullptr) const

Gibt die IPv4-Adresse als Zahl zurück.

Wenn die Adresse beispielsweise 127.0.0.1 lautet, ist der zurückgegebene Wert 2130706433 (d. h. 0x7f000001).

Dieser Wert ist gültig, wenn die Funktion „ protocol()“ den Wert „ IPv4Protocol “ zurückgibt oder wenn das Protokoll „ IPv6Protocol “ ist und die IPv6-Adresse eine IPv4-abgebildete Adresse (RFC4291) ist. In diesen Fällen wird „ ok “ auf „true“ gesetzt. Andernfalls wird es auf „false“ gesetzt.

Siehe auch ` toString()`.

Q_IPV6ADDR QHostAddress::toIPv6Address() const

Gibt die IPv6-Adresse als Q_IPV6ADDR-Struktur zurück. Die Struktur besteht aus 16 vorzeichenlosen Zeichen.

Q_IPV6ADDR addr = hostAddr.toIPv6Address();
// addr contains 16 unsigned characters

for (int i = 0; i < 16; ++i) {
    // process addr[i]
}

Dieser Wert ist gültig, wenn die Funktion „ protocol()“ den Wert „ IPv6Protocol “ zurückgibt. Ist das Protokoll „ IPv4Protocol “, wird die Adresse als IPv4-abgebildete IPv6-Adresse zurückgegeben. (RFC4291)

Siehe auch ` toString()`.

QString QHostAddress::toString() const

Gibt die Adresse als Zeichenkette zurück.

Wenn die Adresse beispielsweise die IPv4-Adresse 127.0.0.1 ist, lautet die zurückgegebene Zeichenkette „127.0.0.1“. Bei IPv6 entspricht das Zeichenfolgenformat der Empfehlung aus RFC 5952. Für QHostAddress::Any wird die zugehörige IPv4-Adresse zurückgegeben („0.0.0.0“).

Siehe auch toIPv4Address().

bool QHostAddress::operator!=(QHostAddress::SpecialAddress other) const

Gibt „ true “ zurück, wenn diese Hostadresse nicht mit der angegebenen Adresse „ other “ übereinstimmt; andernfalls wird „ false “ zurückgegeben.

bool QHostAddress::operator!=(const QHostAddress &other) const

Gibt „ true “ zurück, wenn diese Host-Adresse nicht mit der angegebenen Adresse „ other “ übereinstimmt; andernfalls wird „ false “ zurückgegeben.

QHostAddress &QHostAddress::operator=(QHostAddress::SpecialAddress address)

Weist diesem Objekt die Sonderadresse „ address “ zu und gibt eine Referenz auf dieses Objekt zurück.

Siehe auch setAddress().

QHostAddress &QHostAddress::operator=(const QHostAddress &address)

Weist diesem Objekt eine andere Host- address zu und gibt eine Referenz auf dieses Objekt zurück.

bool QHostAddress::operator==(QHostAddress::SpecialAddress other) const

Gibt „ true “ zurück, wenn diese Hostadresse mit der angegebenen Adresse „ other “ übereinstimmt; andernfalls wird „ false “ zurückgegeben.

bool QHostAddress::operator==(const QHostAddress &other) const

Gibt „ true “ zurück, wenn diese Hostadresse mit der angegebenen Adresse „ other “ übereinstimmt; andernfalls wird „ false “ zurückgegeben. Dieser Operator ruft lediglich „ isEqual “ (alternativ „ StrictConversion “) auf.

Siehe auch isEqual().

Verwandte Nicht-Mitglieder

[noexcept] size_t qHash(const QHostAddress &key, size_t seed = 0)

Gibt den Hashwert für key zurück, wobei seed als Startwert für die Berechnung verwendet wird.

bool operator!=(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)

Gibt „ false “ zurück, wenn die Sonderadresse lhs mit der Hostadresse rhs übereinstimmt; andernfalls wird „ true “ zurückgegeben.

Siehe auch isEqual().

QDataStream &operator<<(QDataStream &out, const QHostAddress &address)

Schreibt die Host-Adresse address in den Stream out und gibt eine Referenz auf den Stream zurück.

Siehe auch „Serialisierung vonQt-Datentypen“.

bool operator==(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)

Gibt „ true “ zurück, wenn die spezielle Adresse lhs mit der Host-Adresse rhs übereinstimmt; andernfalls wird „ false “ zurückgegeben.

Siehe auch isEqual().

QDataStream &operator>>(QDataStream &in, QHostAddress &address)

Liest eine Host-Adresse aus dem Stream „ in “ in „ address “ ein und gibt eine Referenz auf den Stream zurück.

Siehe auch „Serialisierung vonQt-Datentypen“.

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.