Sur cette page

Utilisation Qt Assistant

Capture d'écran de Qt Assistant présentant les widgets destinés à la documentation

Vous pouvez consulter la documentation dans la fenêtre « Documentation ». Pour ouvrir une rubrique dans un nouvel onglet, cliquez avec le bouton droit de la souris dessus dans la fenêtre « Sommaire » afin d’afficher un menu contextuel, puis sélectionnez « Ouvrir le lien dans un nouvel onglet ». Toutes les rubriques ouvertes sont répertoriées dans la fenêtre « Pages ouvertes ». Sélectionnez une rubrique pour l’afficher dans la fenêtre « Documentation ».

Si vous souhaitez que la fenêtre « Documentation » occupe autant d’espace que possible, vous pouvez facilement regrouper, déplacer ou masquer les fenêtres de la barre latérale. Pour regrouper les fenêtres, faites glisser l’une d’elles sur l’autre, puis relâchez le bouton de la souris. Si une ou toutes les fenêtres de la barre latérale ne s’affichent pas, utilisez les raccourcis clavier pour les afficher. Vous pouvez consulter les raccourcis clavier dans le menu « Affichage ».

Les fenêtres de la barre latérale peuvent être ancrées dans la fenêtre principale ; vous pouvez ainsi les faire glisser vers le haut, la gauche, la droite ou le bas de la fenêtre principale, ou les faire glisser hors de l Qt Assistant e pour les afficher en tant que fenêtres indépendantes.

Pour modifier la police et la taille des caractères de la fenêtre du navigateur affichant la documentation ou de l’application elle-même, sélectionnez Édition > Préférences > Polices.

Capture d'écran présentant le menu des préférences de Qt Assistant permettant de modifier les paramètres de police

Pour augmenter ou réduire temporairement la taille de la police dans la fenêtre de documentation, sélectionnez Affichage > Zoom avant ou Zoom arrière. Pour rétablir la taille normale, sélectionnez Affichage > Taille normale.

Pour naviguer entre les pages, sélectionnez Aller > Précédente ou Suivante. Cela vous amène à la page précédente ou suivante dans l’historique. Pour revenir à la page d’accueil, sélectionnez Aller > Accueil. Pour définir la page d’accueil, sélectionnez Édition > Préférences > Options.

Pour synchroniser la fenêtre « Sommaire » avec la page actuellement affichée dans la fenêtre « Documentation », sélectionnez Aller > Synchroniser avec le sommaire.

La barre d’adresse permet de saisir rapidement l’URL d’un fichier de documentation. Pour afficher la barre d’adresse, sélectionnez Affichage > Barres d’outils > Barre d’adresse.

Recherche dans le contenu de la page

Pour rechercher du texte sur la page actuelle, sélectionnez Édition > Rechercher dans le texte. Saisissez le terme de recherche dans le champ. La recherche est incrémentielle, ce qui signifie que le résultat le plus pertinent s'affiche au fur et à mesure que vous saisissez des caractères dans le champ.

Si vous cochez la case « Distinguer majuscules et minuscules », la recherche tient compte de la casse du terme recherché. Par exemple, si vous recherchez « spin », le résultat correspondra à « spin » mais pas à « Spin ».

Pour effectuer une recherche vers l’avant ou vers l’arrière à partir de votre position actuelle sur la page, cliquez sur « Précédent » ou « Suivant ».

Pour masquer la boîte de dialogue de recherche, cliquez sur « Fermer » ou appuyez sur la touche Échap.

Recherche en texte intégral

Capture d'écran du menu de recherche de <span translate=Qt Assistant permettant de parcourir la documentation" src="images/assistant-search.png" title="Capture d'écran du menu de recherche de Qt Assistant permettant de parcourir la documentation"/>

Qt Assistant offre un puissant moteur de recherche en texte intégral. Vous pouvez rechercher des mots ou du texte spécifiques dans la fenêtre « Recherche ». Saisissez le texte que vous souhaitez rechercher, puis appuyez sur Entrée ou cliquez sur « Rechercher ». La recherche n’est pas sensible à la casse. Par exemple, « Foo », « fOo » et « FOO » sont tous traités de la même manière.

Vous pouvez créer des requêtes complexes à l’aide de la syntaxe de requête FTS.

Voici quelques exemples de modèles de recherche courants :

  • deep – répertorie tous les documents contenant le mot « deep »
  • deep* – répertorie tous les documents contenant un mot commençant par « deep »
  • deep copy – répertorie tous les documents contenant à la fois « deep » et « copy »
  • "deep copy" – répertorie tous les documents contenant l’expression « deep copy »

La liste des documents trouvés est classée en fonction du nombre d’occurrences du texte recherché qu’ils contiennent, ceux qui en contiennent le plus apparaissant en premier. Il suffit de cliquer sur n’importe quel document de la liste pour l’afficher dans la fenêtre « Documentation ».

Si la documentation a été modifiée — par exemple, si des documents ont été ajoutés ou supprimés —, « Qt Assistant » les indexera à nouveau.

Filtrage du contenu de l’aide

Qt Assistant vous permet d’installer n’importe quel type de documentation, à condition qu’elle soit organisée dans des fichiers d’aide compressés Qt (*.qch). Par exemple, vous pouvez consulter la documentation de référence Qt pour plusieurs versions de Qt en même temps. À bien des égards, cela s’avère très pratique puisqu’une seule version d’ Qt Assistant suffit. Cependant, cela complique également certaines tâches, comme la recherche dans l’index, car la plupart des mots-clés sont définis dans plusieurs versions de Qt XML. Cela signifie qu’ Qt Assistant demandera toujours à l’utilisateur de choisir celle qui doit s’afficher.

Nous utilisons des filtres de documentation pour résoudre ce problème. Un filtre est identifié par son nom et contient une liste d’attributs de filtre. Un attribut est simplement une chaîne de caractères et peut être choisi librement. Les attributs sont définis par la documentation elle-même, ce qui signifie que chaque ensemble de documentation possède généralement un ou plusieurs attributs.

Par exemple, la documentation Qt Assistant définit les attributs assistant et tools, tandis que Qt Widgets Designer définit designer et tools. Le filtre permettant d’afficher tous les outils ne définirait alors que l’attribut tools, puisque cet attribut fait partie des deux ensembles de documentation. L’ajout de l’attribut assistant au filtre n’afficherait alors que la documentation de Qt Assistant, car la documentation de Designer d’ Qt Widgets ne contient pas cet attribut. Une liste d’attributs vide dans un filtre correspondra à toute la documentation. Autrement dit, cela revient à demander la documentation sans filtrage.

Pour créer et supprimer des filtres de documentation, sélectionnez Édition > Préférences > Filtres.

Capture d'écran présentant le menu des préférences de Qt Assistant permettant de filtrer les catégories à afficher

Pour ajouter un nouveau filtre, cliquez sur « Ajouter », indiquez un nom de filtre, puis cliquez sur « OK ». Sélectionnez ensuite les attributs du filtre dans le champ « Attributs ».

Pour supprimer un filtre, sélectionnez-le et cliquez sur « Supprimer ».

La barre d’outils des filtres vous permet d’appliquer un filtre à la documentation actuellement installée. Pour afficher la barre d’outils des filtres, sélectionnez Affichage > Barres d’outils > Barre d’outils des filtres.

Ajout de documentation

Pour installer et supprimer des fichiers d'aide compressés, sélectionnez Édition > Préférences > Documentation.

Capture d'écran présentant le menu des préférences de Qt Assistant permettant d'ajouter ou de supprimer des éléments de la liste de la documentation

Cliquez sur le bouton « Installer » et choisissez le chemin d'accès du fichier d'aide compressé (*.qch) que vous souhaitez installer. Pour supprimer un fichier d'aide, sélectionnez un ensemble de documentation dans la liste, puis cliquez sur « Supprimer ».

Remarque : les fichiers d’aide compressés Qt (.qch) ne doivent être chargés qu’à partir de sources fiables.

Spécification de la page d’accueil

Pour définir la page d'accueil que Qt Assistant affiche lorsque vous cliquez sur le bouton Accueil, sélectionnez Édition > Préférences > Options.

Saisissez l’URL de la page d’accueil ou sélectionnez « Page actuelle » pour définir la page actuellement affichée comme page d’accueil. Pour laisser la page d’accueil vide, sélectionnez « Page vierge ». Sélectionnez « Restaurer les valeurs par défaut » pour rétablir la page d’accueil par défaut.

Utilisation des options de ligne de commande

Qt Assistant prend en charge les options de ligne de commande suivantes :

Option de ligne de commandeBrève description
-collectionFile <fichier.qhc>Utilise le fichier de collection spécifié à la place de celui par défaut.
-showUrl <URL>Affiche le document référencé par l’URL.
-enableRemoteControlActive le contrôle à distance d'Qt Assistant.
-show <widget>Affiche la fenêtre de la barre latérale spécifiée, qui peut être « contenu », « index », « signets » ou « recherche ».
-hide <widget>Masque la fenêtre de la barre latérale spécifiée, qui peut être « contents », « index », « bookmarks » ou « search ».
-activate <widget>Active la fenêtre de la barre latérale spécifiée, qui peut être « contenu », « index », « signets » ou « recherche ».
-register <doc.qch>Enregistre le fichier d’aide compressé spécifié dans la collection d’aide indiquée.
-unregister <doc.qch>Désenregistre le fichier d’aide compressé spécifié du fichier de collection indiqué.
-remove-search-indexVide l'index du moteur de recherche de l'aide. Cette option est utile si les fichiers d'index associés sont corrompus. La commande « Qt Assistant » réindexera la documentation au prochain démarrage.
-rebuild-search-indexReconstruit l’index du moteur de recherche de l’aide. Notez que cette opération peut prendre un certain temps.
-setCurrentFilter <filtre>Définit le filtre indiqué comme filtre actif.
-quietN'affiche aucun message d'erreur, d'avertissement ou de réussite.

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.