QHostAddress Class
La classe QHostAddress fournit une adresse IP. En savoir plus...
| En-tête : | #include <QHostAddress> |
| CMake : | find_package(Qt6 REQUIRED COMPONENTS Network) target_link_libraries(mytarget PRIVATE Qt6::Network) |
| qmake : | QT += network |
- Liste de tous les membres, y compris les membres hérités
- QHostAddress fait partie de l'API de programmation réseau et des classes partagées implicitement.
Types publics
| flags | ConversionMode |
| enum | ConversionModeFlag { StrictConversion, ConvertV4MappedToIPv4, ConvertV4CompatToIPv4, ConvertLocalHost, ConvertUnspecifiedAddress, TolerantConversion } |
| enum | SpecialAddress { Null, LocalHost, LocalHostIPv6, Broadcast, AnyIPv4, …, Any } |
Fonctions publiques
| QHostAddress() | |
| QHostAddress(QHostAddress::SpecialAddress address) | |
| QHostAddress(const QString &address) | |
| QHostAddress(const Q_IPV6ADDR &ip6Addr) | |
| QHostAddress(const quint8 *ip6Addr) | |
| QHostAddress(const sockaddr *sockaddr) | |
| QHostAddress(quint32 ip4Addr) | |
| QHostAddress(const QHostAddress &address) | |
(since 6.8) | QHostAddress(QHostAddress &&other) |
| ~QHostAddress() | |
| void | clear() |
| bool | isBroadcast() const |
| bool | isEqual(const QHostAddress &other, QHostAddress::ConversionMode mode = TolerantConversion) const |
| bool | isGlobal() const |
| bool | isInSubnet(const QHostAddress &subnet, int netmask) const |
| bool | isInSubnet(const std::pair<QHostAddress, int> &subnet) const |
| bool | isLinkLocal() const |
| bool | isLoopback() const |
| bool | isMulticast() const |
| bool | isNull() const |
(since 6.6) bool | isPrivateUse() const |
| bool | isSiteLocal() const |
| bool | isUniqueLocalUnicast() const |
| int | protocol() const |
| QString | scopeId() const |
| void | setAddress(quint32 ip4Addr) |
| void | setAddress(QHostAddress::SpecialAddress address) |
| bool | setAddress(const QString &address) |
| void | setAddress(const Q_IPV6ADDR &ip6Addr) |
| void | setAddress(const quint8 *ip6Addr) |
| void | setAddress(const sockaddr *sockaddr) |
| void | setScopeId(const QString &id) |
| void | swap(QHostAddress &other) |
| quint32 | toIPv4Address(bool *ok = nullptr) const |
| Q_IPV6ADDR | toIPv6Address() const |
| QString | toString() const |
| bool | operator!=(QHostAddress::SpecialAddress other) const |
| bool | operator!=(const QHostAddress &other) const |
| QHostAddress & | operator=(QHostAddress::SpecialAddress address) |
| QHostAddress & | operator=(const QHostAddress &address) |
| bool | operator==(QHostAddress::SpecialAddress other) const |
| bool | operator==(const QHostAddress &other) const |
Membres publics statiques
| std::pair<QHostAddress, int> | parseSubnet(const QString &subnet) |
Éléments non membres associés
| size_t | qHash(const QHostAddress &key, size_t seed = 0) |
| bool | operator!=(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs) |
| QDataStream & | operator<<(QDataStream &out, const QHostAddress &address) |
| bool | operator==(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs) |
| QDataStream & | operator>>(QDataStream &in, QHostAddress &address) |
Description détaillée
Cette classe contient une adresse IPv4 ou IPv6 indépendamment de la plate-forme et du protocole.
QHostAddress est généralement utilisée avec les fonctions QTcpSocket, QTcpServer et QUdpSocket pour se connecter à un hôte ou pour configurer un serveur.
Une adresse d’hôte est définie à l’aide de ` setAddress()`, puis récupérée à l’aide de ` toIPv4Address()`, ` toIPv6Address()` ou ` toString()`. Vous pouvez vérifier le type à l’aide de ` protocol()`.
Remarque : veuillez noter que QHostAddress n'effectue pas de résolutions DNS. Pour cela, il faut utiliser QHostInfo.
La classe prend également en charge les adresses prédéfinies courantes : Null, LocalHost, LocalHostIPv6, Broadcast et Any.
Voir également QHostInfo, QTcpSocket, QTcpServer et QUdpSocket.
Documentation sur les types de membres
enum QHostAddress::ConversionModeFlag
flags QHostAddress::ConversionMode
| Constante | Valeur | Description |
|---|---|---|
QHostAddress::StrictConversion | 0 | Ne pas convertir les adresses IPv6 en IPv4 lors de la comparaison de deux objets « QHostAddress » de protocoles différents, afin qu’ils soient toujours considérés comme différents. |
QHostAddress::ConvertV4MappedToIPv4 | 1 | Convertir les adresses IPv6 mappées en IPv4 (RFC 4291, section 2.5.5.2) lors de la comparaison. Par conséquent, QHostAddress(« ::ffff:192.168.1.1 ») sera considéré comme égal à QHostAddress(« 192.168.1.1 »). |
QHostAddress::ConvertV4CompatToIPv4 | 2 | Convertir les adresses IPv6 compatibles IPv4 (RFC 4291, section 2.5.5.1) lors de la comparaison. Par conséquent, QHostAddress(« ::192.168.1.1 ») sera considéré comme équivalent à QHostAddress(« 192.168.1.1 »). |
QHostAddress::ConvertLocalHost | 8 | Convertir les adresses de bouclage IPv6 en leur équivalent IPv4 lors de la comparaison. Ainsi, par exemple, QHostAddress(« ::1 ») sera considéré comme égal à QHostAddress(« 127.0.0.1 »). |
QHostAddress::ConvertUnspecifiedAddress | 4 | Toutes les adresses non spécifiées seront considérées comme égales, à savoir AnyIPv4, AnyIPv6 et Any. |
QHostAddress::TolerantConversion | 0xff | Définit les trois indicateurs précédents. |
Le type ConversionMode est un typedef pour QFlags<ConversionModeFlag>. Il stocke une combinaison OR de valeurs ConversionModeFlag.
Voir également isEqual().
enum QHostAddress::SpecialAddress
| Constante | Valeur | Description |
|---|---|---|
QHostAddress::Null | 0 | L'objet d'adresse nulle. Équivalent à QHostAddress(). Voir également QHostAddress::isNull(). |
QHostAddress::LocalHost | 2 | L'adresse IPv4 de l'hôte local. Équivaut à QHostAddress(« 127.0.0.1 »). |
QHostAddress::LocalHostIPv6 | 3 | L'adresse IPv6 de l'hôte local. Équivalent à QHostAddress(« ::1 »). |
QHostAddress::Broadcast | 1 | L'adresse de diffusion IPv4. Équivalente à QHostAddress(« 255.255.255.255 »). |
QHostAddress::AnyIPv4 | 6 | L'adresse « any » IPv4. Équivalente à QHostAddress(« 0.0.0.0 »). Un socket lié à cette adresse n'écoutera que sur les interfaces IPv4. |
QHostAddress::AnyIPv6 | 5 | L'adresse « any » IPv6. Équivaut à QHostAddress(« :: »). Un socket lié à cette adresse n'écoutera que sur les interfaces IPv6. |
QHostAddress::Any | 4 | L'adresse générique double pile. Un socket lié à cette adresse écoutera à la fois sur les interfaces IPv4 et IPv6. |
Documentation des fonctions membres
QHostAddress::QHostAddress()
Crée un objet d'adresse hôte nulle, c'est-à-dire une adresse qui n'est valable pour aucun hôte ni aucune interface.
Voir aussi ` clear()`.
QHostAddress::QHostAddress(QHostAddress::SpecialAddress address)
Crée un objet QHostAddress pour address.
[explicit] QHostAddress::QHostAddress(const QString &address)
Crée une adresse IPv4 ou IPv6 à partir de la chaîne « address » (par exemple, « 127.0.0.1 »).
Voir également setAddress().
[explicit] QHostAddress::QHostAddress(const Q_IPV6ADDR &ip6Addr)
Crée un objet d'adresse hôte avec l'adresse IPv6 ip6Addr.
[explicit] QHostAddress::QHostAddress(const quint8 *ip6Addr)
Crée un objet d'adresse hôte avec l'adresse IPv6 ip6Addr.
ip6Addr Doit être un tableau de 16 octets au format « network byte order » (big-endian).
[explicit] QHostAddress::QHostAddress(const sockaddr *sockaddr)
Crée une adresse IPv4 ou IPv6 à partir de l'adresse spécifiée par la structure native sockaddr.
Voir également setAddress().
[explicit] QHostAddress::QHostAddress(quint32 ip4Addr)
Crée un objet d'adresse hôte avec l'adresse IPv4 ip4Addr.
QHostAddress::QHostAddress(const QHostAddress &address)
Crée une copie de l'address.
[constexpr noexcept default, since 6.8] QHostAddress::QHostAddress(QHostAddress &&other)
La fonction « Move » construit un nouvel objet `QHostAddress` à partir de ` other`.
Remarque : l'objet d'origine other est placé dans un état partiellement formé, dans lequel les seules opérations valides sont la destruction et l'affectation d'une nouvelle valeur.
Cette fonction a été introduite dans Qt 6.8.
[noexcept] QHostAddress::~QHostAddress()
Supprime l'objet d'adresse hôte.
void QHostAddress::clear()
Définit l'adresse hôte sur null et le protocole sur QAbstractSocket::UnknownNetworkLayerProtocol.
Voir également QHostAddress::Null.
bool QHostAddress::isBroadcast() const
Renvoie « true » si l'adresse est l'adresse de diffusion IPv4, « false » dans le cas contraire. L'adresse de diffusion IPv4 est 255.255.255.255.
Notez que cette fonction ne renvoie pas « true » pour l'adresse de diffusion locale d'un réseau IPv4. Pour cela, veuillez utiliser QNetworkInterface afin d'obtenir les adresses de diffusion de la machine locale.
Voir également isLoopback(), isGlobal(), isMulticast(), isLinkLocal(), isUniqueLocalUnicast() et isPrivateUse().
bool QHostAddress::isEqual(const QHostAddress &other, QHostAddress::ConversionMode mode = TolerantConversion) const
Renvoie « true » si cette adresse hôte correspond à l'adresse « other » fournie ; sinon, renvoie « false ».
Le paramètre mode contrôle les conversions effectuées entre les adresses de protocoles différents. Si aucune valeur de mode n’est fournie, la conversion TolerantConversion est effectuée par défaut.
Voir également ConversionMode et operator==().
bool QHostAddress::isGlobal() const
Renvoie true si l'adresse est une adresse globale IPv4 ou IPv6, false dans le cas contraire. Une adresse globale est une adresse qui n'est pas réservée à des fins particulières (comme le loopback ou la multidiffusion) ni à des fins futures.
Notez que les adresses unicast locales uniques IPv6 sont considérées comme des adresses globales (voir isUniqueLocalUnicast()), tout comme les adresses IPv4 réservées aux réseaux locaux par la RFC 1918.
Notez également que les adresses IPv6 locales au site sont obsolètes et doivent être considérées comme globales dans les nouvelles applications. Cette fonction renvoie également « true » pour les adresses locales au site.
Voir également isLoopback(), isSiteLocal(), isUniqueLocalUnicast() et isPrivateUse().
bool QHostAddress::isInSubnet(const QHostAddress &subnet, int netmask) const
Renvoie « true » si cette adresse IP appartient au sous-réseau décrit par le préfixe de réseau subnet et le masque de réseau netmask.
Le paramètre netmask correspond à la longueur du préfixe, c'est-à-dire au nombre de bits de tête utilisés pour identifier la partie réseau de l'adresse. Pour IPv4, les valeurs valides vont de 0 à 32 ; pour IPv6, de 0 à 128.
Une adresse IP est considérée comme appartenant à un sous-réseau si elle se situe entre l’adresse la plus basse et l’adresse la plus haute de ce sous-réseau. Dans le cas de la version 4 du protocole IP, l’adresse la plus basse est l’adresse réseau, tandis que l’adresse la plus haute est l’adresse de diffusion.
L’argument ` subnet ` ne doit pas nécessairement correspondre à l’adresse réseau réelle (l’adresse la plus basse du sous-réseau). Il peut s’agir de n’importe quelle adresse IP valide appartenant à ce sous-réseau. En particulier, s’il est égal à l’adresse IP détenue par cet objet, cette fonction renverra toujours `true` (à condition que la longueur du préfixe soit une valeur valide).
Voir également parseSubnet().
bool QHostAddress::isInSubnet(const std::pair<QHostAddress, int> &subnet) const
Renvoie « true » si cette adresse IP se trouve dans le sous-réseau décrit par « subnet ». Le membre « QHostAddress » de « subnet » contient le préfixe du réseau et le membre « int » (second) contient le masque de réseau (longueur du préfixe).
Il s'agit d'une fonction surchargée.
bool QHostAddress::isLinkLocal() const
Renvoie « true » si l'adresse est une adresse locale de liaison IPv4 ou IPv6, et « false » dans le cas contraire.
Une adresse locale de liaison IPv4 est une adresse appartenant au réseau 169.254.0.0/16. Une adresse locale de liaison IPv6 est une adresse appartenant au réseau fe80::/10. Pour plus d’informations, consultez le registre des espaces d’adressage IPv6 de l’IANA.
Voir également isLoopback(), isGlobal(), isMulticast(), isSiteLocal(), isUniqueLocalUnicast() et isPrivateUse().
bool QHostAddress::isLoopback() const
renvoie « true » si l'adresse correspond à l'adresse de bouclage IPv6 ou à l'une des adresses de bouclage IPv4.
bool QHostAddress::isMulticast() const
Renvoie « true » si l'adresse est une adresse de multidiffusion IPv4 ou IPv6, et « false » dans le cas contraire.
Voir également isLoopback(), isGlobal(), isLinkLocal(), isSiteLocal(), isUniqueLocalUnicast() et isPrivateUse().
bool QHostAddress::isNull() const
Renvoie « true » si cette adresse d'hôte n'est valide pour aucun hôte ni aucune interface.
Le constructeur par défaut crée une adresse nulle.
Voir également QHostAddress::Null.
[since 6.6] bool QHostAddress::isPrivateUse() const
Renvoie « true » si l'adresse est une adresse IPv6 locale unique en unicast ou une adresse IPv4 réservée aux réseaux locaux par la RFC 1918; sinon, elle renvoie « false ».
Cette fonction a été introduite dans Qt 6.6.
Voir également isLoopback(), isGlobal(), isMulticast(), isLinkLocal(), isUniqueLocalUnicast() et isBroadcast().
bool QHostAddress::isSiteLocal() const
Renvoie « true » si l'adresse est une adresse IPv6 locale au site, et « false » dans le cas contraire.
Une adresse IPv6 locale au site est une adresse appartenant au réseau fec0::/10. Pour plus d’informations, consultez le registre des espaces d’adressage IPv6 de l’IANA.
Les adresses IPv6 locales au site sont obsolètes et ne doivent pas être utilisées dans les nouvelles applications. Les nouvelles applications ne doivent pas dépendre de cette fonction et doivent considérer les adresses locales au site comme des adresses globales (c’est pourquoi isGlobal() renvoie également « true »). Les adresses locales au site ont été remplacées par les adresses locales uniques (ULA).
Voir également isLoopback(), isGlobal(), isMulticast(), isLinkLocal(), isUniqueLocalUnicast() et isPrivateUse().
bool QHostAddress::isUniqueLocalUnicast() const
Renvoie « true » si l'adresse est une adresse IPv6 locale unique en unicast, et « false » dans le cas contraire.
Une adresse IPv6 locale unique en unicast est une adresse appartenant au réseau fc00::/7. Pour plus d’informations, consultez le registre des espaces d’adressage IPv6 de l’IANA.
Notez que les adresses unicast locales uniques sont également considérées comme des adresses globales. La RFC 4193 précise qu’en pratique, « les applications peuvent traiter ces adresses comme des adresses de portée globale ». Seuls les routeurs doivent tenir compte de cette distinction.
Voir également isLoopback(), isGlobal(), isMulticast(), isLinkLocal() et isPrivateUse().
[static] std::pair<QHostAddress, int> QHostAddress::parseSubnet(const QString &subnet)
Analyse les informations relatives à l'adresse IP et au sous-réseau contenues dans subnet et renvoie le préfixe réseau correspondant ainsi que la longueur de ce préfixe.
L'adresse IP et le masque de réseau doivent être séparés par une barre oblique (/).
Cette fonction prend en charge les arguments sous la forme :
- 123.123.123.123/n, où n est une valeur comprise entre 0 et 32
- 123.123.123.123/255.255.255.255
- <adresse IPv6>/n où n est une valeur comprise entre 0 et 128
Pour la version 4 du protocole IP, cette fonction accepte également les composants finaux manquants (c'est-à-dire moins de 4 octets, comme « 192.168.1 »), suivis ou non d'un point. Si le masque de réseau est également manquant dans ce cas, il est défini sur le nombre d'octets effectivement transmis (dans l'exemple ci-dessus, ce serait 24, pour 3 octets).
Voir également isInSubnet().
int QHostAddress::protocol() const
Renvoie le protocole de la couche réseau associé à l'adresse de l'hôte.
QString QHostAddress::scopeId() const
Renvoie l'identifiant de portée d'une adresse IPv6. Pour les adresses IPv4, ou si l'adresse ne contient pas d'identifiant de portée, une chaîne vide ( QString ) est renvoyée.
L’identifiant de portée IPv6 spécifie la portée d’accessibilité des adresses IPv6 non globales, limitant ainsi la zone dans laquelle l’adresse peut être utilisée. Toutes les adresses IPv6 sont associées à une telle portée d’accessibilité. L’identifiant de portée sert à lever toute ambiguïté concernant les adresses dont l’unicité globale n’est pas garantie.
IPv6 spécifie les quatre niveaux d’accessibilité suivants :
- Local au nœud : adresses utilisées uniquement pour communiquer avec des services sur la même interface (par exemple, l’interface de bouclage « ::1 »).
- Local à la liaison : adresses propres à l’interface réseau (liaison). Il existe toujours une adresse locale à la liaison pour chaque interface IPv6 de votre hôte. Les adresses locales à la liaison (« fe80... ») sont générées à partir de l’adresse MAC de la carte réseau locale et leur unicité n’est pas garantie.
- Globales : pour les adresses routables à l’échelle mondiale, telles que celles des serveurs publics sur Internet.
Lorsque vous utilisez une adresse locale de liaison ou locale de site pour des connexions IPv6, vous devez spécifier l’identifiant de portée. L’identifiant de portée d’une adresse locale de liaison correspond généralement au nom de l’interface (par exemple, « eth0 », « en1 ») ou à son numéro (par exemple, « 1 », « 2 »).
Voir également setScopeId(), QNetworkInterface et QNetworkInterface::interfaceFromName.
void QHostAddress::setAddress(quint32 ip4Addr)
Définissez l'adresse IPv4 indiquée par ip4Addr.
void QHostAddress::setAddress(QHostAddress::SpecialAddress address)
Définit l'adresse spéciale spécifiée par address.
Il s'agit d'une fonction surchargée.
bool QHostAddress::setAddress(const QString &address)
Définit l'adresse IPv4 ou IPv6 spécifiée par la représentation sous forme de chaîne indiquée par ` address ` (par exemple, « 127.0.0.1 »). Renvoie ` true ` et définit l'adresse si celle-ci a été analysée avec succès ; sinon, renvoie ` false`.
Il s'agit d'une fonction surchargée.
void QHostAddress::setAddress(const Q_IPV6ADDR &ip6Addr)
Définit l'adresse IPv6 spécifiée par ip6Addr.
Il s'agit d'une fonction surchargée.
void QHostAddress::setAddress(const quint8 *ip6Addr)
Définissez l'adresse IPv6 spécifiée par ip6Addr.
ip6Addr Il doit s'agir d'un tableau de 16 octets dans l'ordre des octets du réseau (octet de poids fort en premier).
Il s'agit d'une fonction surchargée.
void QHostAddress::setAddress(const sockaddr *sockaddr)
Définit l'adresse IPv4 ou IPv6 spécifiée par la structure native ` sockaddr`. Renvoie ` true ` et définit l'adresse si celle-ci a été analysée avec succès ; sinon, renvoie ` false`.
Il s'agit d'une fonction surchargée.
void QHostAddress::setScopeId(const QString &id)
Définit l'identifiant de portée IPv6 de l'adresse sur « id ». Si le protocole de l'adresse n'est pas IPv6, cette fonction n'a aucun effet. L’ID de portée peut être défini sous la forme d’un nom d’interface (tel que « eth0 » ou « en1 ») ou d’un nombre entier représentant l’index de l’interface. Si id est un nom d’interface, QtNetwork le convertira en un index d’interface à l’aide de QNetworkInterface::interfaceIndexFromName() avant d’appeler les fonctions réseau du système d’exploitation.
Voir également scopeId(), QNetworkInterface et QNetworkInterface::interfaceFromName.
[noexcept] void QHostAddress::swap(QHostAddress &other)
Permute cette adresse hôte avec celle de other. Cette opération est très rapide et ne rate jamais.
quint32 QHostAddress::toIPv4Address(bool *ok = nullptr) const
Renvoie l'adresse IPv4 sous forme de nombre.
Par exemple, si l'adresse est 127.0.0.1, la valeur renvoyée est 2130706433 (c'est-à-dire 0x7f000001).
Cette valeur est valide si l'protocol() est IPv4Protocol, ou si le protocole est IPv6Protocol, et si l'adresse IPv6 est une adresse mappée IPv4 (RFC4291). Dans ces cas, ok sera défini sur true. Sinon, il sera défini sur false.
Voir également toString().
Q_IPV6ADDR QHostAddress::toIPv6Address() const
Renvoie l'adresse IPv6 sous la forme d'une structure Q_IPV6ADDR. Cette structure est composée de 16 caractères non signés.
Q_IPV6ADDR addr = hostAddr.toIPv6Address();
// addr contains 16 unsigned characters
for (int i = 0; i < 16; ++i) {
// process addr[i]
}Cette valeur est valide si la fonction ` protocol()` renvoie ` IPv6Protocol`. Si le protocole est ` IPv4Protocol`, l'adresse est alors renvoyée sous la forme d'une adresse IPv6 mappée en IPv4. (RFC4291)
Voir également toString().
QString QHostAddress::toString() const
Renvoie l'adresse sous forme de chaîne de caractères.
Par exemple, si l'adresse est l'adresse IPv4 127.0.0.1, la chaîne renvoyée est « 127.0.0.1 ». Pour IPv6, le format de la chaîne de caractères suivra la recommandation RFC5952. Pour QHostAddress::Any, c'est son adresse IPv4 qui sera renvoyée (« 0.0.0.0 »)
Voir aussi toIPv4Address().
bool QHostAddress::operator!=(QHostAddress::SpecialAddress other) const
Renvoie « true » si cette adresse hôte ne correspond pas à l’adresse « other » fournie ; sinon, renvoie « false ».
bool QHostAddress::operator!=(const QHostAddress &other) const
Renvoie « true » si cette adresse d'hôte ne correspond pas à l'adresse « other » fournie ; sinon, renvoie « false ».
QHostAddress &QHostAddress::operator=(QHostAddress::SpecialAddress address)
Attribue l'adresse spéciale address à cet objet et renvoie une référence à celui-ci.
Voir également setAddress().
QHostAddress &QHostAddress::operator=(const QHostAddress &address)
Attribue une autre adresse hôte address à cet objet et renvoie une référence à cet objet.
bool QHostAddress::operator==(QHostAddress::SpecialAddress other) const
Renvoie « true » si cette adresse hôte correspond à l'adresse « other » fournie ; sinon, renvoie « false ».
bool QHostAddress::operator==(const QHostAddress &other) const
Renvoie « true » si cette adresse hôte est identique à l'adresse « other » fournie ; sinon, renvoie « false ». Cet opérateur appelle simplement « isEqual » (autre, « StrictConversion »).
Voir également isEqual().
Éléments non membres associés
[noexcept] size_t qHash(const QHostAddress &key, size_t seed = 0)
Renvoie la valeur de hachage de key, en utilisant seed comme graine pour le calcul.
bool operator!=(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)
Renvoie « false » si l'adresse spéciale lhs est identique à l'adresse hôte rhs; sinon, renvoie « true ».
Voir également isEqual().
QDataStream &operator<<(QDataStream &out, const QHostAddress &address)
Écrit l'adresse hôte address dans le flux out et renvoie une référence à ce flux.
Voir également Sérialisation des types de données Qt.
bool operator==(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)
Renvoie « true » si l'adresse spéciale lhs correspond à l'adresse de l'hôte rhs; sinon, renvoie « false ».
Voir également isEqual().
QDataStream &operator>>(QDataStream &in, QHostAddress &address)
Lit une adresse hôte dans le fichier « address » à partir du flux « in » et renvoie une référence à ce flux.
Voir également Sérialisation des types de données Qt.
© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.