本页内容

从Blender导出

可以从 Blender 中导出网格、灯光、摄像机、变换动画(缩放/旋转/位置)、UV 布局、枢轴点、对象层级结构以及材质槽。

导出模型

创建材质槽

在导出前,必须在 Blender 中创建并分配材质槽。若未进行此操作,则该对象将使用一个默认材质槽。

注意:只有 已分配材质且在导出对象上已分配给网格的材质槽才会被导入。

要创建材质槽,请按照以下步骤操作。

  1. 在属性面板中,选择“material ”选项卡。
  2. 点击“+ ”按钮以添加新的材质槽。
  3. 点击“New ”按钮。

    Blender 材质属性面板中,“新建”按钮被高亮显示

  4. 对要创建的每个材质槽,重复步骤 2 至 4。

默认情况下,第一个材质槽将被分配给该对象。

若要为对象分配不同的材质槽,或为同一个对象分配多个材质槽,请按照以下步骤操作。

  1. 在编辑模式下,选择所需的面。(按住 Shift 键并右键单击进行多选,按A 键选择所有面)。
  2. 在属性面板中,选择“材质”选项卡。
  3. 在材质槽列表中,选择所需的材质槽。
  4. 点击“Assign ”按钮,将所选材质槽分配给选中的面。

    Blender 视口中显示的绿色立方体及其材质属性面板

模型的 UV 展开

对模型进行UV展开将生成UV布局。如果没有UV布局,您将无法在Qt Quick 3D 中对模型渲染任何纹理。

展开 3D 网格的方法和技巧有很多种。下面介绍在 Blender 中进行此操作的最基本方法。

  1. 在编辑模式下,按A键选中整个网格。
  2. 按下U键,并在上下文菜单中选择“Unwrap ”。

    Blender 的 UV 映射菜单,其中“展开”选项已被选中

三角化

  1. 在对象模式下,选择该对象。
  2. 在属性面板中,选择“修改器”选项卡。
  3. 在下拉列表中,选择“Triangulate ”。

    Blender 的“添加修饰符”菜单中,“三角化”选项被高亮显示

  4. 按Apply 。

注意:当 以COLLADA格式导出时 ,可以在实际的导出步骤中进行三角化。

动画的烘焙操作

注意: 只有当您导出的动画使用自定义曲线或对象约束来控制动画时,才需要执行此 步骤。

动作是包含动画数据的数据块。如果您正在导出动画,则需要烘焙动作。

  1. 按空格键。
  2. 输入“烘焙动作”。
  3. 按Enter键。

应用位置、旋转和缩放

注意: 导出动画时不应执行此操作 。

应用变换值会重置对象的位置、旋转和缩放值。位置和旋转值将更改为 0,而缩放值将更改为 1。对象本身在外观上不会发生变化。

  1. 在对象模式下,选择该对象。
  2. 按Ctrl + A键。
  3. 选择“Location ”。
  4. 在面板中的复选框中,同时勾选“Rotation ”和“Scale ”。

    Blender“应用”菜单中显示“位置”选项

注意:应用 “位置”也会重置对象的原点(枢轴点)。

导出灯光

您可以将任何类型的灯光从 Blender 导出,以便在Qt Quick 3D 中使用。

将导入以下属性:

  • 位置、旋转、缩放
  • 亮度
  • 光源颜色
  • 投射阴影

已导入光源类型(如有需要会进行转换)。

Blender 中的光类型将以以下形式导入Qt Quick 3D...
点点
面面
太阳方向
聚光定向
Hemi定向

导出摄像机

您可以将透视摄像机和正交摄像机从Blender导出,以便在Qt Quick 3D 中使用。

将导入以下属性:

  • 位置、旋转、缩放
  • 裁剪起始/结束位置
  • 焦距(仅限透视摄像机)。

从 Blender 导出 COLLADA

  1. 从“文件”菜单中,选择“File > Export > Collada (.dae) ”。
  2. 请确保已勾选“Triangulation ”选项,除非您已经将所有网格进行了三角化。
  3. 点击“Export COLLADA ”按钮。

从 Blender 导出 FBX

若要以 FBX 格式导出,必须在 Blender 中安装并启用 FBX 导出插件。Blender 的默认安装中应已包含该Import-Export: FBX format 。若未显示“以 FBX 格式导出”选项,请按照以下步骤确保已启用该插件:

  1. 选择“File > User Preferences ”。
  2. 从顶部菜单栏中选择“Add-ons ”。
  3. 搜索fbx。
  4. 此时该插件应已显示,请勾选其名称旁边的复选框以启用它。

Blender 用户首选项中显示已启用 FBX 格式插件

接下来,要导出为 FBX,请按照以下步骤操作:

  1. 选择“File > Export > FBX (.fbx) ”。
  2. 在“Main ”选项卡下,将“Forward ”设置为“Y Forward ”,将“Up ”设置为“Z Up ”。

    Blender FBX 导出轴设置中显示 Y 轴向前、Z 轴向上

  3. 对于动画,请确保在“Animation ”选项卡中勾选了“Baked Animation ”选项。

    Blender 的 FBX 导出设置,其中“烘焙动画”选项已勾选

  4. 点击“Export FBX ”按钮。

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.