Qt Widgets Widget-Bearbeitungsmodus im Designer

Im Widget-Bearbeitungsmodus können Objekte aus der Widget-Box des Hauptfensters auf ein Formular gezogen, bearbeitet, in der Größe angepasst, auf dem Formular verschoben und sogar zwischen Formularen hin- und hergezogen werden. Objekteigenschaften lassen sich interaktiv ändern, sodass Änderungen sofort sichtbar sind. Die Bearbeitungsoberfläche ist für einfache Vorgänge intuitiv, unterstützt aber dennoch die leistungsstarken Layout-Funktionen von Qt.
Um neue Formulare zu erstellen und zu bearbeiten, öffnen Sie das Menü „Datei“ und wählen Sie „Neues Formular…“ oder drücken Sie Strg+N. Vorhandene Formulare können ebenfalls bearbeitet werden , indem Sie im Menü „Datei“ die Option „Formular öffnen…“ auswählen oder Strg+O drücken.
Sie können Ihr Formular jederzeit speichern, indem Sie im Menü „Datei“ die Option „Speichern unter…“ auswählen. Die vom „ Qt Widgets -Designer“ gespeicherten UI-Dateien enthalten Informationen zu den verwendeten Objekten sowie alle Details zu den Signal- und Slot-Verbindungen zwischen ihnen.
Ein Formular bearbeiten
Standardmäßig werden neue Formulare im Widget-Bearbeitungsmodus geöffnet. Um von einem anderen Modus in den Bearbeitungsmodus zu wechseln, wählen Sie im Menü „Bearbeiten“ den Eintrag „Widgets bearbeiten“ aus oder drücken Sie die Taste F3.
Objekte werden dem Formular hinzugefügt, indem man sie aus dem Haupt-Widget-Feld an die gewünschte Stelle im Formular zieht und dort ablegt. Dort angekommen, lassen sie sich einfach durch Ziehen oder mithilfe der Cursortasten verschieben. Durch gleichzeitiges Drücken der Strg-Taste wird das ausgewählte Widget Pixel für Pixel verschoben, während die Verwendung der Cursortasten allein bewirkt, dass das ausgewählte Widget beim Verschieben am Raster ausrichtet. Objekte können durch Klicken mit der linken Maustaste ausgewählt werden. Sie können auch die Tabulatortaste verwenden, um die Auswahl zu wechseln.
Die Widget-Box enthält Objekte aus verschiedenen Kategorien, die alle nach Bedarf auf dem Formular platziert werden können. Die einzigen Objekte, die etwas mehr Vorbereitung erfordern, sind die Container-Widgets. Diese werden im Kapitel „Verwendung von Containern im Qt Widgets -Designer“ näher beschrieben.
![]() | Objekte auswählen Objekte auf dem Formular werden durch Klicken mit der linken Maustaste ausgewählt. Wenn ein Objekt ausgewählt ist, werden an jeder Ecke und in der Mitte jeder Seite Größenänderungsgriffe angezeigt, die darauf hinweisen, dass die Größe des Objekts geändert werden kann. Um weitere Objekte auszuwählen, halten Sie die Strg-Taste gedrückt und klicken Sie auf die Objekte. Sind mehrere Objekte ausgewählt, wird das aktuell ausgewählte Objekt mit Größenänderungsgriffen in einer anderen Farbe angezeigt. Um ein Widget innerhalb eines Layouts zu verschieben, halten Sie die Umschalt- und die Strg-Taste gedrückt, während Sie das Widget ziehen. Dadurch wird die Auswahl auf das übergeordnete Layout des Widgets erweitert. Alternativ können Objekte im Objektinspektor ausgewählt werden. |
Wenn ein Widget ausgewählt ist, können die üblichen Zwischenablagefunktionen wie Ausschneiden, Kopieren und Einfügen darauf angewendet werden. Alle diese Vorgänge können bei Bedarf ausgeführt und rückgängig gemacht werden.
Die folgenden Tastenkombinationen können verwendet werden:
| Aktion | Tastenkombination | Beschreibung |
|---|---|---|
| Ausschneiden | Strg+X | Schneidet die ausgewählten Objekte aus und legt sie in die Zwischenablage. |
| Kopieren | Strg+C | Kopiert die ausgewählten Objekte in die Zwischenablage. |
| Einfügen | Strg+V | Fügt die Objekte aus der Zwischenablage in das Formular ein. |
| Löschen | Löschen | Löscht die ausgewählten Objekte. |
| Objekt klonen | Strg+Ziehen (linke Maustaste) | Erstellt eine Kopie des ausgewählten Objekts oder der ausgewählten Objektgruppe. |
| Vorschau | Strg+R | Zeigt eine Vorschau des Formulars an. |
Alle oben genannten Aktionen (mit Ausnahme des Klonens) sind sowohl über das Menü „Bearbeiten“ als auch über das Kontextmenü des Formulars zugänglich. Diese Menüs bieten außerdem Funktionen zum Anordnen von Objekten sowie eine Funktion „Alle auswählen“, mit der alle Objekte auf dem Formular ausgewählt werden können.
Widgets sind keine eindeutigen Objekte; Sie können so viele Kopien davon erstellen, wie Sie benötigen. Um ein Widget schnell zu duplizieren, können Sie es klonen, indem Sie die Strg-Taste gedrückt halten und es ziehen. Auf diese Weise lassen sich Widgets schneller kopieren und auf dem Formular platzieren als mit Zwischenablage-Vorgängen.
![]() | Drag & Drop Qt Widgets Der Designer nutzt die von Qt bereitgestellten Drag-and-Drop-Funktionen in großem Umfang. Widgets können aus der Widget-Box auf das Formular gezogen und dort abgelegt werden. Widgets können auf dem Formular auch „geklont“ werden: Wenn Sie die Strg-Taste gedrückt halten und das Widget ziehen, wird eine Kopie des Widgets erstellt, die an eine neue Position gezogen werden kann. Es ist zudem möglich, Widgets in den Objekt-Inspektor zu ziehen, um verschachtelte Layouts einfach zu verwalten. |
Qt Widgets Mit dem Designer lassen sich ausgewählte Objekte kopieren, einfügen und zwischen Formularen verschieben. Mit dieser Funktion können Sie mehrere Kopien desselben Formulars erstellen und in jeder davon mit unterschiedlichen Layouts experimentieren.
Der Eigenschaftseditor
Der Eigenschafteneditor zeigt stets die Eigenschaften des aktuell ausgewählten Objekts auf dem Formular an. Die verfügbaren Eigenschaften hängen vom jeweils bearbeiteten Objekt ab, doch alle bereitgestellten Widgets verfügen über gemeinsame Eigenschaften wie „ objectName “ (Objektname), den internen Namen des Objekts, und „ enabled “ (Interaktivität), die Eigenschaft, die festlegt, ob mit einem Objekt interagiert werden kann oder nicht.
![]() | Bearbeiten von Eigenschaften Der Eigenschaftseditor verwendet Standard-Qt-Widgets, um die Eigenschaften von Objekten im Formular zu verwalten. Textuelle Eigenschaften werden in Zeileneingabefeldern angezeigt, ganzzahlige Eigenschaften in Drehfeldern, boolesche Eigenschaften in Kontrollkästchen und zusammengesetzte Eigenschaften wie Farben und Größen in Dropdown-Listen der Widgets angezeigt. Geänderte Eigenschaften werden durch fettgedruckte Beschriftungen gekennzeichnet. Um sie zurückzusetzen, klicken Sie auf die Pfeilschaltfläche auf der rechten Seite. Änderungen an Eigenschaften werden auf alle ausgewählten Objekte angewendet, die dieselbe Eigenschaft aufweisen. |
Bestimmte Eigenschaften werden vom Eigenschafteneditor besonders behandelt:
- Zusammengesetzte Eigenschaften – Eigenschaften, die aus mehr als einem Wert bestehen – werden als Knoten dargestellt, die sich aufklappen lassen, sodass ihre Werte bearbeitet werden können.
- Eigenschaften, die eine Auswahl an Kennzeichen enthalten, werden über Kombinationsfelder mit ankreuzbaren Elementen bearbeitet.
- Eigenschaften, die den Zugriff auf komplexe Datentypen ermöglichen, wie z. B. „ QPalette “, werden über Dialogfelder geändert, die sich bei der Bearbeitung der Eigenschaften öffnen. „ QLabel “ und die Widgets im Abschnitt „Buttons“ der Widget-Box verfügen über die Eigenschaft „
text“, die ebenfalls durch Doppelklick auf das Widget oder durch Drücken der Taste F2 bearbeitet werden kann. „ Qt Widgets “ Der Designer interpretiert das Backslash-Zeichen (\) auf besondere Weise, sodass Zeilenumbruchzeichen (\n) in den Text eingefügt werden können; die Zeichenfolge \\ wird verwendet, um einen einzelnen Backslash in den Text einzufügen. Während der Bearbeitung kann auch ein Kontextmenü geöffnet werden, das eine weitere Möglichkeit bietet, Sonderzeichen und Zeilenumbrüche in den Text einzufügen.
Dynamische Eigenschaften
Der Eigenschaftseditor kann auch verwendet werden, um sowohl Standard-Qt-Widgets als auch den Formularen selbst neue „ dynamic properties “ hinzuzufügen. Seit Qt 4.4 werden dynamische Eigenschaften über die unten abgebildete Symbolleiste des Eigenschaftseditors hinzugefügt und entfernt.

Um eine dynamische Eigenschaft hinzuzufügen, klicken Sie auf die Schaltfläche „Hinzufügen“ (
). Um sie zu entfernen, klicken Sie stattdessen auf die Schaltfläche „Entfernen“ (
). Sie können die Eigenschaften außerdem alphabetisch sortieren und die Farbgruppen ändern, indem Sie auf die Schaltfläche „Konfigurieren“ (
) klicken.
Der Objekt-Inspektor
![]() | Der Objekt-Inspector Der Objekt-Inspektor zeigt eine hierarchische Liste aller Objekte des aktuell bearbeiteten Formulars an. Um die untergeordneten Objekte eines Container-Widgets oder eines Layouts anzuzeigen, klicken Sie auf den Griff neben der Objektbezeichnung. Jedes Objekt auf einem Formular kann durch Klicken auf den entsprechenden Eintrag im Objekt-Inspektor ausgewählt werden. Ein Rechtsklick öffnet das Kontextmenü des Formulars. Diese Funktionen können nützlich sein, wenn Sie viele sich überlappende Objekte haben. Um ein Objekt im Objekt-Inspektor zu suchen, verwenden Sie Strg+F. Seit Qt 4.4 können Sie durch Doppelklick auf den Namen des Objekts dessen Namen mit dem In-Place-Editor ändern. Seit Qt 4.5 zeigt der Objekt-Inspektor den Layout-Status der Container an. Das Symbol für ein fehlerhaftes Layout ###ICON wird angezeigt, wenn bei den Layouts ein Fehler vorliegt. |
© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.



