Sur cette page

Exportation depuis Blender

Il est possible d'exporter des maillages, des lumières, des caméras, des animations de transformation (échelle/rotation/position), des mappages UV, des points de pivot, la hiérarchie des objets et les emplacements de matériaux depuis Blender.

Exportation de modèles

Créer des emplacements de matériaux

Les emplacements de matériaux doivent être créés et attribués dans Blender avant l'exportation. Si cela n'est pas fait, un emplacement de matériau par défaut est utilisé pour l'objet.

Remarque : seuls les emplacements de matériaux contenant un matériau et attribués à un maillage de l'objet exporté seront importés.

Pour créer des emplacements de matériaux, suivez les étapes ci-dessous.

  1. Dans le panneau des propriétés, sélectionnez l'onglet « material ».
  2. Cliquez sur « + » pour ajouter un nouvel emplacement de matériau.
  3. Cliquez sur le bouton « New ».

    Panneau des propriétés des matériaux de Blender avec le bouton « Nouveau » mis en surbrillance

  4. Répétez les étapes 2 à 4 pour chaque emplacement de matériau à créer.

Par défaut, le premier emplacement de matériau sera attribué à l’objet.

Pour attribuer un emplacement de matériau différent à l’objet, ou pour attribuer plusieurs emplacements de matériau au même objet, suivez les étapes ci-dessous.

  1. En mode édition, sélectionnez les faces souhaitées. (Maj + clic droit pour sélectionner plusieurs faces, A pour sélectionner toutes les faces).
  2. Dans le panneau des propriétés, sélectionnez l'onglet « Matériau ».
  3. Dans la liste des emplacements de matériau, sélectionnez l'emplacement de matériau souhaité.
  4. Cliquez sur le bouton « Assign » pour attribuer l'emplacement de matériau sélectionné aux faces choisies.

    Fenêtre de visualisation de Blender affichant un cube vert avec le panneau des propriétés du matériau

Déplier les modèles en UV

Le dépliage UV de votre modèle permettra de créer un plan UV. Sans ce plan UV, vous ne pourrez pas appliquer de textures à votre modèle dans Qt Quick 3D.

Il existe de nombreuses méthodes et techniques différentes pour déplier des maillages 3D. La méthode la plus simple pour le faire dans Blender est décrite ci-dessous.

  1. En mode Édition, appuyez sur A pour sélectionner l'ensemble du maillage.
  2. Appuyez sur la touche U et sélectionnez « Unwrap » dans le menu contextuel.

    Menu « UV Mapping » de Blender avec l'option « Unwrap » sélectionnée

Trianguler

  1. En mode Objet, sélectionnez l’objet.
  2. Dans le panneau des propriétés, sélectionnez l'onglet « Modificateurs ».
  3. Dans la liste déroulante, sélectionnez « Triangulate ».

    Menu « Ajouter un modificateur » de Blender avec l'option « Trianguler » mise en évidence

  4. Appuyez sur « Apply ».

Remarque : lors de l'exportation au format COLLADA, il est possible d'effectuer la triangulation lors de l'étape d'exportation proprement dite.

Actions de « bake » pour les animations

Remarque : cette étape n’est nécessaire que si vous exportez des animations utilisant des courbes personnalisées ou des contraintes d’objet pour contrôler l’animation.

Les actions sont des blocs de données contenant des données d'animation. Si vous exportez des animations, vous devez « cuire » les actions.

  1. Appuyez sur la barre d'espace.
  2. Tapez « bake actions ».
  3. Appuyez sur la touche Entrée.

Appliquer la position, la rotation et l'échelle

Remarque : cette opération ne doit pas être effectuée lors de l’exportation d’animations.

L'application des valeurs de transformation réinitialise les valeurs de position, de rotation et d'échelle de l'objet. Les valeurs de position et de rotation sont remises à 0, tandis que celles d'échelle sont remises à 1. L'objet lui-même ne subit aucun changement visuel.

  1. En mode Objet, sélectionnez l’objet.
  2. Appuyez sur les touches Ctrl + A.
  3. Sélectionnez « Location ».
  4. Dans le panneau, cochez également les cases « Rotation » et « Scale ».

    Menu « Apply » de Blender affichant l'option « Location »

Remarque : l’application de l’option « Emplacement » réinitialise également l’origine (point de pivot) de l’objet.

Exportation des lumières

Vous pouvez exporter des lumières de n'importe quel type depuis Blender pour les utiliser dans Qt Quick 3D.

Les propriétés suivantes sont importées :

  • Position, rotation, échelle
  • Luminosité
  • Couleur de la lumière
  • Ombres projetées

Le type de lumière est importé (et converti si nécessaire).

Type de lumière dans BlenderSera importé dans Qt Quick 3D sous la forme...
PointPoint
SurfaceSurface
SoleilDirectionnel
SpotDirectionnel
HemiDirectionnel

Exportation de caméras

Vous pouvez exporter des caméras en perspective et orthographiques depuis Blender pour les utiliser dans Qt Quick 3D.

Les propriétés suivantes sont importées :

  • Position, rotation, échelle
  • Début/fin de découpage
  • Distance focale (caméra en perspective uniquement).

Exportation au format COLLADA depuis Blender

  1. Dans le menu Fichier, sélectionnez « File > Export > Collada (.dae) ».
  2. Assurez-vous que l'option « Triangulation » est cochée, sauf si vous avez déjà triangulé tous les maillages.
  3. Cliquez sur le bouton « Export COLLADA ».

Exportation au format FBX depuis Blender

Pour exporter au format FBX, vous devez avoir installé et activé le module complémentaire d'exportation FBX dans Blender. Avec l'installation par défaut de Blender, le module « Import-Export: FBX format » devrait être installé. Si l'option d'exportation au format FBX n'est pas disponible, assurez-vous que le module complémentaire est activé en suivant les étapes suivantes :

  1. Sélectionnez « File > User Preferences ».
  2. Sélectionnez « Add-ons » dans la barre de menu supérieure.
  3. Recherchez « fbx ».
  4. L'extension devrait désormais être visible ; activez-la en cochant la case située à côté de son nom.

Les préférences utilisateur de Blender indiquent que l'extension pour le format FBX est activée

Ensuite, pour exporter au format FBX, procédez comme suit :

  1. Sélectionnez « File > Export > FBX (.fbx) ».
  2. Dans l'onglet « Main », définissez « Forward » sur « Y Forward » et « Up » sur « Z Up ».

    Paramètres d'exportation FBX de Blender indiquant « Y vers l'avant » et « Z vers le haut »

  3. Pour les animations, assurez-vous que l’option « Baked Animation » est cochée dans l’onglet « Animation ».

    Paramètres d'exportation FBX de Blender avec l'option « Animation cuite » cochée

  4. Cliquez sur le bouton « Export FBX ».

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.