このページでは

SVGビューア

SVG ファイルのレンダリングおよび表示を行う「Qt Widgets 」のサンプルです。

SVGファイルを表示しているSVGビューアツールのスクリーンショット

この Qt SVG モジュールはQPainter を使用してSVGファイルをレンダリングし、このサンプルではQt Widgets を使用してレンダリングされたSVGファイルを表示する方法を示しています。描画領域全体はQScrollArea 内に配置されています。これにより、ユーザーがSVG画像を拡大したい場合、2つのスクロールバーが自動的に表示され、操作が容易になります。 さらに、レンダリングされたSVGファイルをラスタライズされた画像としてエクスポートするオプションも用意されています。

レンダリング

ファイルを開くには、ファイルアイコンをクリックするか、[ファイル] メニューから[開く] をクリックします。その後、ファイルシステム内を移動して SVG ファイルを選択します。 Qt SVG は、ソフトウェアレンダラーを使用してファイルの内容を描画します。これにより、ピクセル単位のアンチエイリアシングと豊富な機能が提供されます。ただし、複雑なSVGファイルの場合、CPUにかなりの負荷がかかる可能性があります。ハードウェアアクセラレーション対応のSVGレンダラーを使用するには、代わりにVectorImage を使用してください。 Qt SVG ファイルを読み込むさまざまな方法については、「Qt における 2D グラフィックス」のページを参照してください。

SVG ビューアには、現在開いている SVG ファイルを再読み込みするための「更新」ボタンが用意されています。このボタンは「表示」メニューからも利用できます。さらに、「表示」メニューには「自動更新」オプションがあり、ファイルが変更されるたびにビューアが自動的に再描画を行うように設定できます。

SVGビューアには、「白」、「黒」、「チェッカー」の3種類の背景オプションが用意されています。これらのオプションは、ツールバーのアイコンまたは[背景]メニューからアクセスできます。さらに、同じメニューには、レンダリングされたSVGファイルの周囲のアウトラインを表示または非表示にするボタンもあります。

機能

Qt 6.7以降、このモジュールには追加機能が搭載されました。以前は、このモジュールはSVG Tiny 1.2のみをサポートしていました。「機能」メニューを使用すると、これらの新機能を有効または無効にできます。たとえば、レンダラーをSVG Tiny 1.2の機能セットに制限したり、アニメーションを完全に無効にしたりすることができます。 これらの機能の詳細については、QtSvg::Option のドキュメントページを参照してください。

サンプルプロジェクト @ code.qt.io

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.