블렌더에서 내보내기
블렌더에서는 메시, 조명, 카메라, 변환 애니메이션(크기/회전/위치), UV 레이아웃, 피벗 포인트, 오브젝트 계층 구조 및 머티리얼 슬롯을 내보낼 수 있습니다.
모델 내보내기
머티리얼 슬롯 생성
내보내기 전에 Blender에서 머티리얼 슬롯을 생성하고 할당해야 합니다. 이 작업을 수행하지 않으면 오브젝트에 하나의 기본 머티리얼 슬롯이 사용됩니다.
참고: 머티리얼이 지정되어 있고, 내보낸 오브젝트의 메시에 할당된 머티리얼슬롯만 가져오게 됩니다.
머티리얼 슬롯을 생성하려면 다음 단계를 따르세요.
- 속성 패널에서 ‘ material ’ 탭을 선택합니다.
- ' + '을 눌러 새 머티리얼 슬롯을 추가합니다.
- New 버튼을 누릅니다.

- 생성할 각 머티리얼 슬롯에 대해 2~4단계를 반복합니다.
기본적으로 첫 번째 머티리얼 슬롯이 오브젝트에 할당됩니다.
오브젝트에 다른 머티리얼 슬롯을 할당하거나, 동일한 오브젝트에 여러 머티리얼 슬롯을 할당하려면 아래 단계를 따르십시오.
- 편집 모드에서 원하는 면을 선택합니다. (Shift + 마우스 오른쪽 클릭 으로 여러 개를 선택하고, A를 눌러 모든 면을 선택합니다).
- 속성 패널에서 머티리얼 탭을 선택합니다.
- 머티리얼 슬롯 목록에서 원하는 머티리얼 슬롯을 선택합니다.
- Assign 버튼을 눌러 선택한 머티리얼 슬롯을 선택한 면에 할당합니다.

모델의 UV 언랩
모델의 UV 언랩을 수행하면 UV 레이아웃이 생성됩니다. UV 레이아웃이 없으면 Qt Quick 3D 에서 모델에 텍스처를 렌더링할 수 없습니다.
3D 메쉬를 언랩하는 방법과 기법은 매우 다양합니다. Blender에서 가장 기본적인 방법은 다음과 같습니다.
- 편집 모드에서 A 키를 눌러 메쉬 전체를 선택합니다.
- U 키를 누르고 컨텍스트 메뉴에서 ‘ Unwrap ’를 선택합니다.

삼각형 분할
- 오브젝트 모드에서 오브젝트를 선택합니다.
- 속성 패널에서 '모디파이어(Modifiers)' 탭을 선택합니다.
- 드롭다운 목록에서 ‘ Triangulate ’를 선택합니다.

- Apply 를 누르십시오.
참고: COLLADA로 내보낼때 , 실제 내보내기 단계에서 삼각형 분할을 수행할 수 있습니다.
애니메이션용 베이킹 작업
참고: 이 단계는 애니메이션을 제어하기 위해 사용자 정의 커브나 오브젝트 제약 조건을 사용하는 애니메이션을 내보내는 경우에만 필요합니다.
액션은 애니메이션 데이터가 포함된 데이터 블록입니다. 애니메이션을 내보내는 경우, 액션을 베이킹해야 합니다.
- 스페이스 바 를 누르십시오.
- " 액션 베이킹"을 입력합니다.
- Enter 키를 누릅니다.
위치, 회전 및 크기 적용
참고: 애니메이션을 내보낼 때는이 작업을 수행해서는 안 됩니다.
변환 값을 적용하면 오브젝트의 위치, 회전 및 스케일 값이 재설정됩니다. 위치 및 회전 값은 0으로, 스케일 값은 1로 변경됩니다. 오브젝트 자체는 시각적으로 변하지 않습니다.
- 오브젝트 모드에서 오브젝트를 선택합니다.
- Ctrl + A 키를 누릅니다.
- ‘ Location ’를 선택합니다.
- 패널의 확인란에서 ‘ Rotation ’ 및 ‘ Scale ’도 선택합니다.

참고: ‘위치(Location)’를적용하면 오브젝트의 원점(피벗 포인트)도 재설정됩니다.
조명 내보내기
Blender에서 모든 유형의 조명을 내보내어 Qt Quick 3D 에서 사용할 수 있습니다.
다음 속성이 가져옵니다:
- 위치, 회전, 크기
- 밝기
- 광원 색상
- 그림자 투사
광원 유형이 가져오며(필요한 경우 변환됩니다).
| 블렌더의 광원 유형 | Qt Quick 3D 로 다음과 같이 가져옵니다... |
|---|---|
| 점 | 점 |
| 영역 | 영역 |
| 태양 | 방향 |
| 스팟 | 방향성 |
| 헤미 | 방향성 |
카메라 내보내기
블렌더에서 원근 투영 카메라와 직교 투영 카메라를 내보내어 Qt Quick 3D 에서 사용할 수 있습니다.
다음 속성이 가져옵니다:
- 위치, 회전, 크기
- 클리핑 시작/종료
- 초점 거리(원근 카메라에만 해당).
블렌더에서 COLLADA 내보내기
- 파일 메뉴에서 ‘ File > Export > Collada (.dae) ’를 선택하십시오.
- 모든 메시를 이미 삼각형 분할한 경우가 아니라면, ‘ Triangulation ’가 선택되어 있는지 확인하십시오.
- Export COLLADA 버튼을 선택합니다.
Blender에서 FBX 내보내기
FBX로 내보내려면 Blender에 FBX 내보내기 애드온이 설치되어 있고 활성화되어 있어야 합니다. Blender의 기본 설치 환경에서는 ‘ Import-Export: FBX format ’가 설치되어 있습니다. FBX로 내보내기 옵션이 표시되지 않는 경우, 다음 단계를 따라 애드온이 활성화되어 있는지 확인하십시오:
- ' File > User Preferences'을 선택합니다.
- 상단 메뉴 바에서 ‘ Add-ons ’을 선택합니다.
- 'fbx'를 검색합니다.
- 이제 애드온이 표시될 것입니다. 이름 옆의 확인란을 선택하여 활성화하십시오.

다음으로, FBX로 내보내려면 다음 단계를 따르세요:
- ' File > Export > FBX (.fbx)'를 선택하십시오.
- ' Main ' 탭에서 ' Forward '을 '
Y Forward'로, ' Up '을 'Z Up'로 설정하십시오.
- 애니메이션의 경우, ‘ Animation ’ 탭에서 ‘ Baked Animation ’ 옵션이 선택되어 있는지 확인하십시오.

- Export FBX 버튼을 선택하십시오.
© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.