このページでは

Blenderからのエクスポート

Blenderからは、メッシュ、ライト、カメラ、トランスフォームアニメーション(スケール/回転/位置)、UVレイアウト、ピボットポイント、オブジェクト階層、マテリアルスロットをエクスポートすることができます。

モデルのエクスポート

マテリアルスロットの作成

エクスポートする前に、Blenderでマテリアルスロットを作成して割り当てる必要があります。これを行わない場合、オブジェクトには1つのデフォルトのマテリアルスロットが使用されます。

注: マテリアルが設定されており、かつエクスポートされたオブジェクトのメッシュに割り当てられているマテリアルスロットのみが インポートされます。

マテリアルスロットを作成するには、以下の手順に従ってください。

  1. プロパティパネルで、「material 」タブを選択します。
  2. 「+ 」ボタンを押して、新しいマテリアルスロットを追加します。
  3. 「New 」ボタンを押します。

    「新規」ボタンが強調表示されたBlenderのマテリアルプロパティパネル

  4. 作成するマテリアルスロットごとに、手順 2 から 4 を繰り返します。

デフォルトでは、最初のマテリアルスロットがオブジェクトに割り当てられます。

オブジェクトに別のマテリアルスロットを割り当てる場合、または同じオブジェクトに複数のマテリアルスロットを割り当てる場合は、以下の手順に従ってください。

  1. 編集モードで、目的の面を選択します。(Shift キー + マウスの右クリックで複数選択、Aキーですべての面を選択)。
  2. プロパティパネルで、「マテリアル」タブを選択します。
  3. マテリアルスロットリストから、目的のマテリアルスロットを選択します。
  4. 「Assign 」ボタンを押して、選択したマテリアルスロットを選択した面に割り当てます。

    マテリアルプロパティパネルが表示された、緑色の立方体が映し出されたBlenderのビューポート

モデルのUV展開

モデルのUVアンラップを行うと、UVレイアウトが作成されます。UVレイアウトがないと、Qt Quick 3Dでモデルにテクスチャをレンダリングすることはできません。

3D メッシュのアンラップには、さまざまな方法やテクニックがあります。Blender で行う最も基本的な方法を以下に説明します。

  1. 編集モードで、Aキーを押してメッシュ全体を選択します。
  2. Uキーを押し、コンテキストメニューから「Unwrap 」を選択します。

    「Unwrap」オプションが選択されたBlenderのUVマッピングメニュー

三角分割

  1. オブジェクトモードで、オブジェクトを選択します。
  2. プロパティパネルで、「Modifiers」タブを選択します。
  3. ドロップダウンリストから「Triangulate 」を選択します。

    Blenderの「モディファイアを追加」メニューで、「Triangulate」オプションが強調表示されている

  4. 「Apply 」を押します。

注: COLLADA としてエクスポートする場合 、実際のエクスポート手順で三角分割を行うことができます。

アニメーションのアクションのベイク

注:この 手順は、アニメーションの制御にカスタムカーブやオブジェクトの制約を使用しているアニメーションをエクスポートする場合にのみ必要です。

アクションとは、アニメーションデータを含むデータブロックのことです。アニメーションをエクスポートする場合は、アクションをベイクする必要があります。

  1. スペースバーキーを押します。
  2. 「bake actions」と入力します。
  3. Enterキーを押します。

位置、回転、スケールを適用する

注: アニメーションをエクスポートする際は、この操作 を行わないでください。

トランスフォーム値を適用すると、オブジェクトの位置、回転、およびスケールの値がリセットされます。位置と回転の値は 0 に、スケールの値は 1 に変更されます。オブジェクト自体の外観は変わりません。

  1. オブジェクトモードで、オブジェクトを選択します。
  2. Ctrl + Aキーを押します。
  3. 「Location 」を選択します。
  4. パネルのチェックボックスから、「Rotation 」と「Scale 」にもチェックを入れます。

    「Location」オプションが表示されたBlenderの「Apply」メニュー

注: 「Location」を適用すると 、オブジェクトの原点(ピボットポイント)もリセットされます。

ライトのエクスポート

Blender から、Qt Quick 3D で使用するために、あらゆるタイプのライトをエクスポートできます。

以下のプロパティがインポートされます:

  • 位置、回転、スケール
  • 輝度
  • ライトの色
  • 影の投射

ライトの種類がインポートされます(必要に応じて変換されます)。

Blender でのライトタイプQt Quick 3D には次のようにインポートされます...
ポイント点
エリアエリア
太陽方向
スポット指向性
ヘミ指向性

カメラのエクスポート

Blenderからパースペクティブカメラおよび正投影カメラをエクスポートし、Qt Quick 3Dで使用することができます。

以下のプロパティがインポートされます:

  • 位置、回転、スケール
  • クリッピングの開始点/終了点
  • 焦点距離(透視カメラのみ)。

BlenderからのCOLLADAエクスポート

  1. ファイルメニューから、「File > Export > Collada (.dae) 」を選択します。
  2. すべてのメッシュの三角形化がすでに完了している場合を除き、「Triangulation 」がオンになっていることを確認してください。
  3. 「Export COLLADA 」ボタンを選択します。

Blender から FBX をエクスポートする

FBXとしてエクスポートするには、BlenderにFBXエクスポート用アドオンがインストールされ、有効になっている必要があります。Blenderのデフォルトのインストールでは、「Import-Export: FBX format 」がインストールされているはずです。FBXとしてエクスポートするオプションが表示されない場合は、以下の手順に従ってアドオンが有効になっていることを確認してください。

  1. 「File > User Preferences 」を選択します。
  2. 上部メニューバーから「Add-ons 」を選択します。
  3. 「fbx」を検索します。
  4. これでアドオンが表示されるはずです。名前の横にあるチェックボックスを選択して有効にしてください。

Blenderの「ユーザー設定」に、FBX形式のアドオンが有効になっていることが表示されている

次に、FBX形式でエクスポートするには、以下の手順に従ってください:

  1. 「File > Export > FBX (.fbx) 」を選択します。
  2. 「Main 」タブで、「Forward 」を「Y Forward 」に、「Up 」を「Z Up 」に設定します。

    BlenderのFBXエクスポートにおける軸設定で、Y軸が前方、Z軸が上方向になるように表示される

  3. アニメーションを使用する場合は、「Animation 」タブで「Baked Animation 」オプションがチェックされていることを確認してください。

    「ベイク済みアニメーション」オプションがオンになっているBlenderのFBXエクスポート設定

  4. [Export FBX ] ボタンを選択します。

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.