Sur cette page

Traduire des chaînes

Ouvrez les fichiers source de traduction (TS) dans Qt Linguist pour les traduire. Les fichiers TS sont des fichiers XML lisibles par l'utilisateur contenant les phrases sources et leurs traductions. Les fichiers TS sont généralement créés et mis à jour par lupdate. Si vous ne disposez pas d'un fichier TS, consultez la section Création de fichiers de traduction pour savoir comment en générer un.

Vous pouvez également utiliser Qt Linguist pour traduire des fichiers au format XML XLIFF (XML Localization Interchange File Format) générés par d’autres programmes. Cependant, pour les projets Qt standard, seul le format de fichier TS est utilisé. Seules les versions 1.1 et 1.2 du format XLIFF sont actuellement prises en charge.

Qt Linguist affiche la langue cible dans la zone de traduction et adapte en conséquence le nombre de champs de saisie pour les formes plurielles. Lorsque vous ouvrez plusieurs fichiers TS à traduire simultanément, les champs « Translator » et « Translator comment » s’affichent pour chaque langue. Pour plus d’informations sur la configuration des informations de localisation, consultez la section « Modification de la locale cible ».

Si le développeur fournit un commentaire permettant de lever toute ambiguïté, vous pouvez le consulter dans le champ « Developer comments ».

Pour traduire des chaînes :

  1. Sélectionnez « File » > « Open » pour charger un fichier TS.
  2. Sélectionnez un contexte dans la vue « Context » pour afficher les chaînes traduisibles dans la vue « Strings ».

  3. Sélectionnez une chaîne pour l'afficher dans le champ « Source text » de la zone de traduction. Les espaces dans le texte source sont affichés.
  4. Saisissez la traduction de la chaîne actuelle dans le champ « Translation ».

    Double-cliquez sur une traduction existante dans le champ « Phrases and guesses » pour l'utiliser comme traduction de la chaîne actuelle. « Qt Linguist » lit les phrases à partir de recueils de phrases et fonde ses suggestions sur les traductions existantes de phrases similaires dans le fichier TS.

  5. Si vous le souhaitez, saisissez un commentaire à l’intention des autres traducteurs dans le champ « Translator comment ».
  6. Pour accepter la traduction, appuyez sur Ctrl+Entrée, sélectionnez « Icône » ou cliquez sur l’icône située à gauche de la chaîne source sélectionnée dans la liste des chaînes.
  7. Sélectionnez « File » > « Save » pour enregistrer votre travail.

Répétez ce processus jusqu’à ce que toutes les chaînes de la liste soient marquées comme « Icône de vérification » (Accepted/Correct) ou « Vérifier l'icône d'avertissement » (Accepted/Warnings). Sélectionnez ensuite le contexte suivant et continuez.

Pour afficher le nombre de mots et de caractères dans le texte source et dans le texte traduit, sélectionnez « View » > « Statistics ».

Sélectionnez « File » > « Release » pour créer un fichier QM portant le même nom de base que le fichier source de traduction actuel. L’outil « lrelease » effectue la même opération sur tous les fichiers source de traduction d’une application.

Pour imprimer le fichier source de traduction et les traductions, sélectionnez « File » > « Print ».

Pour quitter « Qt Linguist », sélectionnez « File » > « Exit ».

Passer d’une chaîne traduisible à une autre

Pour passer à la traduction inachevée suivante, sélectionnez « Icône » (Next Unfinished) ou appuyez sur Ctrl+J.

Pour passer au texte source suivant, sélectionnez « icône suivante », appuyez sur Ctrl+Maj+J ou sélectionnez « Translation » > « Next ».

Expressions nécessitant plusieurs traductions selon le contexte

Une même expression peut apparaître dans plusieurs contextes sans créer de conflit. Lorsque vous atteignez une autre occurrence d’une expression déjà traduite, « Qt Linguist » propose la traduction précédente comme traduction possible dans la vue « Phrases and guesses ».

Si une expression apparaît plusieurs fois dans un contexte donné, elle n’apparaît qu’une seule fois dans la vue « Context », et la traduction est appliquée à toutes ses occurrences dans ce contexte. Si la même expression a des significations différentes au sein d’un même contexte, le développeur doit ajouter un commentaire pour chaque occurrence de l’expression. Les expressions en double apparaissent dans la vue « Context ». Les commentaires du développeur s’affichent dans la zone de traduction sur un fond bleu clair.

Modification des raccourcis clavier

Un raccourci clavier est une combinaison de touches qui déclenche une action.

Raccourcis avec la touche Alt

Dans le texte des éléments de menu et des boutons, un caractère mnémonique (souligné) indique qu’appuyer sur Alt ou Ctrl en même temps que le caractère souligné déclenche la même action que de cliquer sur l’élément de menu ou d’appuyer sur le bouton.

Par exemple, les applications utilisent souvent la touche F comme caractère mnémonique dans le menu « File » ; vous pouvez donc soit cliquer sur l'élément de menu, soit appuyer sur Alt+F pour ouvrir le menu. Le caractère mnémonique dans la chaîne traduisible est précédé d’une esperluette : \&File. La traduction de la chaîne doit également comporter une esperluette, de préférence devant le même caractère.

Vous pouvez déterminer la signification d’un raccourci clavier avec la touche Alt à partir de la phrase contenant l’esperluette. Vous pouvez utiliser un autre caractère mnémonique si la phrase traduite ne contient pas celui-ci ou s’il est déjà utilisé dans la traduction d’un autre raccourci dans ce contexte. Certains raccourcis clavier, généralement ceux de la barre de menu, peuvent s’appliquer dans d’autres contextes.

Raccourcis clavier avec la touche Ctrl

Les raccourcis avec la touche Ctrl peuvent exister indépendamment de tout contrôle visuel. En général, ils déclenchent des actions dans les menus qui nécessiteraient plusieurs frappes ou clics de souris, ou des actions qui n’apparaissent dans aucun menu ni sur aucun bouton. Par exemple, le menu « File » peut contenir un New Ctrl+N élément que vous pouvez activer en appuyant sur Ctrl+N, même lorsque le menu « File » est fermé.

Chaque raccourci clavier avec la touche Ctrl apparaît dans la vue « Strings » sous la forme d’une chaîne distincte. Par exemple, Ctrl+Entrée. Étant donné que cette chaîne ne dispose pas d’un contexte lui donnant un sens, contrairement au contexte de la phrase dans laquelle apparaît un raccourci clavier avec la touche Alt, vous devez compter sur le développeur pour inclure une « disambiguation comment » expliquant l’action effectuée par le raccourci clavier avec la touche Ctrl. Le commentaire apparaît sous « Developer comments » dans la zone de traduction, sous le champ « Source text ».

Idéalement, vous pouvez copier les traductions des raccourcis clavier « Ctrl » en sélectionnant « Translation » > « Copy from source text ». Toutefois, si le caractère n’a pas de sens dans la langue cible, modifiez-le. Quel que soit le caractère (lettre ou chiffre) que vous choisissez, utilisez la forme « Ctrl+ » suivie du caractère en majuscule. Qt affiche automatiquement le nom correct lors de l'exécution. Comme pour les raccourcis clavier utilisant la touche Alt, si vous modifiez le caractère, assurez-vous qu’il n’entre pas en conflit avec un autre raccourci clavier utilisant la touche Ctrl.

Remarque : ne traduisez pas les parties « Alt », « Ctrl » ou « Maj » des raccourcis, car Qt les reconnaît et les traduit automatiquement pour les langues prises en charge.

Gestion des arguments numérotés et des formes plurielles

Un argument numéroté est un espace réservé qui sera remplacé par du texte lors de l’exécution. Il apparaît dans une chaîne source sous la forme d’un signe pourcentage suivi d’un chiffre. Par exemple, dans la chaîne « After processing file %1, file %2 is next in line », « %1 » et « %2 » sont des arguments numérotés qui sont remplacés par les premier et deuxième noms de fichiers lors de l’exécution. Les mêmes arguments numérotés doivent apparaître dans la traduction, mais pas nécessairement dans le même ordre. Une traduction allemande de cette chaîne pourrait inverser l’ordre des expressions, par exemple Datei %2 wird bearbeitet, wenn Datei %1 fertig ist. Les deux arguments numérotés apparaissent dans la traduction, mais dans l’ordre inverse. Un argument numéroté est toujours remplacé par le même texte dans les traductions, quelle que soit sa position dans la séquence d’arguments de la chaîne source.

L’utilisation d’arguments numérotés s’accompagne souvent de l’emploi de formes plurielles dans le texte source. Dans de nombreuses langues, la forme du texte dépendra de la valeur affichée, et plusieurs traductions sont nécessaires. Si les développeurs ont balisé le texte source correctement, des champs correspondant à chacune des formes plurielles possibles seront disponibles dans la zone de traduction. Pour plus d’informations, consultez la section Rédaction du code source en vue de la traduction.

Gestion des références de caractères numériques (NCR) dans les traductions

Sélectionnez « NCR mode » (Afficher les références de caractères numériques) pour activer ou désactiver l’affichage des références de caractères numériques dans le texte source et dans les champs de traduction. Lorsque cette option est sélectionnée, les caractères spéciaux du texte s’affichent sous la forme de leurs références NCR correspondantes (par exemple,   pour un espace insécable). Sinon, les caractères apparaissent sous leur forme visuelle standard. Cette fonctionnalité est utile, par exemple, pour conserver les mêmes caractères spéciaux (tels que les emojis ou les espaces spéciaux) à la fois dans le texte source et dans ses traductions.

Modification des paramètres régionaux de la langue cible

Vous pouvez définir explicitement les informations de paramètres régionaux dans « Edit > Translation File Settings ». Si la langue et le pays cibles ne sont pas explicitement définis lorsque vous ouvrez un fichier source de traduction, Qt Linguist tente de les déduire à partir du nom du fichier source de traduction. Pour cela, les fichiers de traduction doivent respecter la convention de nommage suivante : appname_language[_country].ts, où :

  • language est un code de langue ISO 639 en minuscules.
  • country est un code de pays ISO 3166 à deux lettres en majuscules.

Si cette tentative de détermination de la langue et du pays cibles échoue, la fenêtre « Translation File Settings » s’ouvre.

Par exemple, app_de.ts définit l’allemand comme langue cible, et app_de_CH.ts définit l’allemand comme langue cible et la Suisse comme pays cible. Cela permet également de charger automatiquement les traductions pour les paramètres régionaux actuels. Pour plus d’informations, consultez la section « Activer la traduction ».

Capture d'écran montrant la fenêtre des paramètres de Qt Linguist, avec la langue source « POSIX » et la langue cible « allemand »

© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.