QHostAddress Class
QHostAddress クラスは IP アドレスを提供します。詳細...
| ヘッダー: | #include <QHostAddress> |
| CMake: | find_package(Qt6 REQUIRED COMPONENTS Network) target_link_libraries(mytarget PRIVATE Qt6::Network) |
| qmake: | QT += network |
- 継承されたメンバーを含むすべてのメンバーの一覧
- QHostAddressは、ネットワークプログラミングAPIおよび暗黙的に共有されるクラスの一部です。
パブリック型
| flags | ConversionMode |
| enum | ConversionModeFlag { StrictConversion, ConvertV4MappedToIPv4, ConvertV4CompatToIPv4, ConvertLocalHost, ConvertUnspecifiedAddress, TolerantConversion } |
| enum | SpecialAddress { Null, LocalHost, LocalHostIPv6, Broadcast, AnyIPv4, …, Any } |
パブリック関数
| QHostAddress() | |
| QHostAddress(QHostAddress::SpecialAddress address) | |
| QHostAddress(const QString &address) | |
| QHostAddress(const Q_IPV6ADDR &ip6Addr) | |
| QHostAddress(const quint8 *ip6Addr) | |
| QHostAddress(const sockaddr *sockaddr) | |
| QHostAddress(quint32 ip4Addr) | |
| QHostAddress(const QHostAddress &address) | |
(since 6.8) | QHostAddress(QHostAddress &&other) |
| ~QHostAddress() | |
| void | clear() |
| bool | isBroadcast() const |
| bool | isEqual(const QHostAddress &other, QHostAddress::ConversionMode mode = TolerantConversion) const |
| bool | isGlobal() const |
| bool | isInSubnet(const QHostAddress &subnet, int netmask) const |
| bool | isInSubnet(const std::pair<QHostAddress, int> &subnet) const |
| bool | isLinkLocal() const |
| bool | isLoopback() const |
| bool | isMulticast() const |
| bool | isNull() const |
(since 6.6) bool | isPrivateUse() const |
| bool | isSiteLocal() const |
| bool | isUniqueLocalUnicast() const |
| int | protocol() const |
| QString | scopeId() const |
| void | setAddress(quint32 ip4Addr) |
| void | setAddress(QHostAddress::SpecialAddress address) |
| bool | setAddress(const QString &address) |
| void | setAddress(const Q_IPV6ADDR &ip6Addr) |
| void | setAddress(const quint8 *ip6Addr) |
| void | setAddress(const sockaddr *sockaddr) |
| void | setScopeId(const QString &id) |
| void | swap(QHostAddress &other) |
| quint32 | toIPv4Address(bool *ok = nullptr) const |
| Q_IPV6ADDR | toIPv6Address() const |
| QString | toString() const |
| bool | operator!=(QHostAddress::SpecialAddress other) const |
| bool | operator!=(const QHostAddress &other) const |
| QHostAddress & | operator=(QHostAddress::SpecialAddress address) |
| QHostAddress & | operator=(const QHostAddress &address) |
| bool | operator==(QHostAddress::SpecialAddress other) const |
| bool | operator==(const QHostAddress &other) const |
静的パブリックメンバ
| std::pair<QHostAddress, int> | parseSubnet(const QString &subnet) |
関連する非メンバー
| size_t | qHash(const QHostAddress &key, size_t seed = 0) |
| bool | operator!=(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs) |
| QDataStream & | operator<<(QDataStream &out, const QHostAddress &address) |
| bool | operator==(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs) |
| QDataStream & | operator>>(QDataStream &in, QHostAddress &address) |
詳細な説明
このクラスは、プラットフォームやプロトコルに依存しない形で IPv4 または IPv6 アドレスを保持します。
QHostAddress は通常、QTcpSocket 、QTcpServer 、およびQUdpSocket と組み合わせて、ホストへの接続やサーバーの設定に使用されます。
ホストアドレスは、setAddress() で設定し、toIPv4Address()、toIPv6Address()、またはtoString() で取得します。protocol() を使用して、そのタイプを確認できます。
注: QHostAddress は DNS 検索を行わない点にご注意ください 。DNS 検索を行うにはQHostInfo が必要です。
また、このクラスは、Null 、LocalHost 、LocalHostIPv6 、Broadcast 、およびAny といった、一般的な事前定義済みアドレスもサポートしています。
QHostInfo 、QTcpSocket 、QTcpServer 、およびQUdpSocketも参照してください 。
メンバ型のドキュメント
enum QHostAddress::ConversionModeFlag
flags QHostAddress::ConversionMode
| 定数 | 値 | 説明 |
|---|---|---|
QHostAddress::StrictConversion | 0 | 異なるプロトコルの 2 つの `QHostAddress ` オブジェクトを比較する際、IPv6 アドレスを IPv4 に変換しないため、それらは常に異なるものとみなされます。 |
QHostAddress::ConvertV4MappedToIPv4 | 1 | 比較時には、IPv4マッピングされたIPv6アドレス(RFC 4291 セクション 2.5.5.2)を変換します。 したがって、QHostAddress (「::ffff:192.168.1.1」)は、QHostAddress (「192.168.1.1」)と等しいとみなされます。 |
QHostAddress::ConvertV4CompatToIPv4 | 2 | 比較の際は、IPv4互換のIPv6アドレス(RFC 4291 セクション 2.5.5.1)に変換します。したがって、QHostAddress (「::192.168.1.1」)は、QHostAddress (「192.168.1.1」)と等しいとみなされます。 |
QHostAddress::ConvertLocalHost | 8 | 比較を行う際、IPv6 ループバックアドレスを IPv4 相当のアドレスに変換します。したがって、例えばQHostAddress("::1") はQHostAddress("127.0.0.1") と等しいとみなされます。 |
QHostAddress::ConvertUnspecifiedAddress | 4 | 指定されていないアドレスはすべて同一とみなされます。具体的には、AnyIPv4 、AnyIPv6 、および Any です。 |
QHostAddress::TolerantConversion | 0xff | 前述の 3 つのフラグをすべて設定します。 |
ConversionMode 型は、QFlags<ConversionModeFlag> の typedef です。これは、ConversionModeFlag 値の OR 組み合わせを格納します。
isEqual()も参照してください 。
enum QHostAddress::SpecialAddress
| 定数 | 値 | 説明 |
|---|---|---|
QHostAddress::Null | 0 | null アドレスオブジェクト。QHostAddress() と同等です。QHostAddress::isNull() も参照してください。 |
QHostAddress::LocalHost | 2 | IPv4のローカルホストアドレス。QHostAddress("127.0.0.1") と同等です。 |
QHostAddress::LocalHostIPv6 | 3 | IPv6のローカルホストアドレス。QHostAddress("::1") と同等です。 |
QHostAddress::Broadcast | 1 | IPv4のブロードキャストアドレス。QHostAddress (「255.255.255.255」)と同等です。 |
QHostAddress::AnyIPv4 | 6 | IPv4の任意アドレス。QHostAddress (「0.0.0.0」)に相当します。このアドレスでバインドされたソケットは、IPv4インターフェースでのみリスニングを行います。 |
QHostAddress::AnyIPv6 | 5 | IPv6 の「any-address」。QHostAddress (「::」)に相当します。このアドレスがバインドされたソケットは、IPv6 インターフェースでのみリスニングを行います。 |
QHostAddress::Any | 4 | デュアルスタックの任意アドレス。このアドレスにバインドされたソケットは、IPv4 および IPv6 の両方のインターフェースでリスニングを行います。 |
メンバ関数のドキュメント
QHostAddress::QHostAddress()
ホストアドレスがNULLのオブジェクト、すなわち、どのホストやインターフェースに対しても有効ではないアドレスを生成します。
clear()も参照してください 。
QHostAddress::QHostAddress(QHostAddress::SpecialAddress address)
address 用の QHostAddress オブジェクトを作成します。
[explicit] QHostAddress::QHostAddress(const QString &address)
文字列「address 」(例:「127.0.0.1」)に基づいて、IPv4 または IPv6 アドレスを生成します。
setAddress()も参照してください 。
[explicit] QHostAddress::QHostAddress(const Q_IPV6ADDR &ip6Addr)
IPv6アドレス「ip6Addr 」を持つホストアドレスオブジェクトを作成します。
[explicit] QHostAddress::QHostAddress(const quint8 *ip6Addr)
IPv6アドレス「ip6Addr 」を持つホストアドレスオブジェクトを構築します。
ip6Addr ネットワークバイト順(ビッグエンディアン)の16バイト配列でなければなりません。
[explicit] QHostAddress::QHostAddress(const sockaddr *sockaddr)
ネイティブ構造体 `sockaddr` で指定されたアドレスを使用して、IPv4 または IPv6 アドレスを生成します。
setAddress()も参照してください 。
[explicit] QHostAddress::QHostAddress(quint32 ip4Addr)
IPv4アドレス「ip4Addr 」を持つホストアドレスオブジェクトを作成します。
QHostAddress::QHostAddress(const QHostAddress &address)
指定されたaddress のコピーを作成します。
[constexpr noexcept default, since 6.8] QHostAddress::QHostAddress(QHostAddress &&other)
other から新しい QHostAddress をムーブコンストラクタで生成します。
注: 移動元のオブジェクト other は 、部分的に形成された状態になります。この状態では、破壊と新しい値への代入のみが有効な操作となります。
この関数は Qt 6.8 で導入されました。
[noexcept] QHostAddress::~QHostAddress()
ホストアドレスオブジェクトを破棄します。
void QHostAddress::clear()
ホストアドレスをnullに設定し、プロトコルをQAbstractSocket::UnknownNetworkLayerProtocol に設定します。
「QHostAddress::Null」も参照してください 。
bool QHostAddress::isBroadcast() const
アドレスがIPv4のブロードキャストアドレスである場合はtrue を返し、それ以外の場合はfalse を返します。IPv4のブロードキャストアドレスは255.255.255.255です。
なお、この関数は、IPv4 ネットワークのローカルブロードキャストアドレスに対しては true を返しません。その場合は、QNetworkInterface を使用して、ローカルマシンのブロードキャストアドレスを取得してください。
関連項目: isLoopback(),isGlobal(),isMulticast(),isLinkLocal(),isUniqueLocalUnicast(), およびisPrivateUse()。
bool QHostAddress::isEqual(const QHostAddress &other, QHostAddress::ConversionMode mode = TolerantConversion) const
このホストアドレスが指定されたother アドレスと一致する場合はtrue を返し、一致しない場合はfalse を返します。
パラメータmode は、異なるプロトコルのアドレス間でどの変換が行われるかを制御します。mode が指定されていない場合、デフォルトではTolerantConversion が実行されます。
ConversionMode およびoperator==()も参照してください 。
bool QHostAddress::isGlobal() const
アドレスがIPv4またはIPv6のグローバルアドレスである場合はtrue を返し、それ以外の場合はfalse を返します。グローバルアドレスとは、特別な目的(ループバックやマルチキャストなど)や将来の用途のために予約されていないアドレスを指します。
なお、IPv6の一意のローカルユニキャストアドレスはグローバルアドレスとみなされます(isUniqueLocalUnicast() を参照)。また、RFC 1918 によってローカルネットワーク用に予約された IPv4 アドレスも同様です。
また、IPv6のサイトローカルアドレスは非推奨となっており、新しいアプリケーションではグローバルアドレスとして扱うべきである点にも注意してください。この関数は、サイトローカルアドレスに対してもtrueを返します。
isLoopback()、isSiteLocal()、isUniqueLocalUnicast()、およびisPrivateUse()も参照してください 。
bool QHostAddress::isInSubnet(const QHostAddress &subnet, int netmask) const
この IP アドレスが、ネットワークプレフィックスsubnet およびネットマスクnetmask で指定されるサブネットに含まれる場合、true を返します。
netmask パラメータはプレフィックス長、つまりアドレスのネットワーク部分を識別するために使用される先頭のビット数です。IPv4 の場合、有効な値は 0 から 32 まで、IPv6 の場合、0 から 128 までです。
IPアドレスは、そのサブネットの最小アドレスと最大アドレスの範囲内に含まれている場合に、そのサブネットに属するとみなされます。IPバージョン4の場合、最小アドレスはネットワークアドレスであり、最大アドレスはブロードキャストアドレスです。
subnet 引数は、必ずしも実際のネットワークアドレス(サブネット内の最小アドレス)である必要はありません。そのサブネットに属する任意の有効なIPアドレスであればよいです。特に、この引数が本オブジェクトが保持するIPアドレスと等しい場合、この関数は常にtrueを返します(プレフィックス長が有効な値である場合に限ります)。
parseSubnet()も参照してください 。
bool QHostAddress::isInSubnet(const std::pair<QHostAddress, int> &subnet) const
この IP がsubnet で指定されたサブネットに含まれている場合、true を返します。subnet のQHostAddress メンバにはネットワークプレフィックスが、int(2 番目の)メンバにはネットマスク(プレフィックス長)が格納されています。
これはオーバーロードされた関数です。
bool QHostAddress::isLinkLocal() const
アドレスが IPv4 または IPv6 のリンクローカルアドレスの場合は `true ` を返し、それ以外の場合は `false ` を返します。
IPv4のリンクローカルアドレスとは、ネットワーク 169.254.0.0/16 内のアドレスを指します。IPv6のリンクローカルアドレスとは、ネットワーク fe80::/10 内のアドレスを指します。詳細については、IANAのIPv6アドレス空間レジストリを参照してください。
isLoopback()、isGlobal()、isMulticast()、isSiteLocal()、isUniqueLocalUnicast()、およびisPrivateUse()も参照してください 。
bool QHostAddress::isLoopback() const
そのアドレスがIPv6のループバックアドレス、またはいずれかのIPv4ループバックアドレスである場合、true を返します。
bool QHostAddress::isMulticast() const
アドレスが IPv4 または IPv6 のマルチキャストアドレスの場合は `true ` を返し、それ以外の場合は `false ` を返します。
isLoopback()、isGlobal()、isLinkLocal()、isSiteLocal()、isUniqueLocalUnicast()、およびisPrivateUse()も参照してください 。
bool QHostAddress::isNull() const
このホストアドレスがいずれのホストやインターフェースに対しても無効である場合、true を返します。
デフォルトのコンストラクタは、null アドレスを作成します。
QHostAddress::Nullも参照してください 。
[since 6.6] bool QHostAddress::isPrivateUse() const
アドレスがIPv6の一意なローカルユニキャストアドレス、またはRFC 1918によってローカルネットワーク用に予約されたIPv4アドレスの場合はtrue を返し、それ以外の場合はfalse を返します。
この関数は Qt 6.6 で導入されました。
関連項目: isLoopback()、isGlobal()、isMulticast()、isLinkLocal()、isUniqueLocalUnicast()、およびisBroadcast()。
bool QHostAddress::isSiteLocal() const
アドレスがIPv6のサイトローカルアドレスの場合はtrue を返し、それ以外の場合はfalse を返します。
IPv6のサイトローカルアドレスとは、ネットワーク fec0::/10 内のアドレスを指します。詳細については、IANAのIPv6アドレス空間レジストリを参照してください。
IPv6 サイトローカルアドレスは非推奨となっており、新しいアプリケーションではこれに依存すべきではありません。新しいアプリケーションはこの関数に依存せず、サイトローカルアドレスをグローバルアドレスと同様に扱う必要があります(これが、isGlobal() も true を返す理由です)。サイトローカルアドレスは、一意のローカルアドレス (ULA) に置き換えられました。
isLoopback()、isGlobal()、isMulticast()、isLinkLocal()、isUniqueLocalUnicast()、およびisPrivateUse()も参照してください 。
bool QHostAddress::isUniqueLocalUnicast() const
アドレスがIPv6の一意なローカルユニキャストアドレスの場合はtrue を返し、それ以外の場合はfalse を返します。
IPv6のユニークローカルユニキャストアドレスとは、fc00::/7 ネットワーク内のアドレスを指します。詳細については、IANA IPv6アドレス空間レジストリを参照してください。
なお、一意のローカルユニキャストアドレスもグローバルアドレスとして扱われることに注意してください。RFC 4193 では、実際には「アプリケーションはこれらのアドレスをグローバルスコープのアドレスと同様に扱うことができる」と規定されています。この区別を気にする必要があるのはルータのみです。
isLoopback()、isGlobal()、isMulticast()、isLinkLocal()、およびisPrivateUse()も参照してください 。
[static] std::pair<QHostAddress, int> QHostAddress::parseSubnet(const QString &subnet)
subnet に含まれるIPおよびサブネット情報を解析し、そのネットワークのネットワークプレフィックスとそのプレフィックス長を返します。
IPアドレスとネットマスクはスラッシュ(/)で区切られている必要があります。
この関数は、次のような形式の引数をサポートしています。
- 123.123.123.123/n(ここで、n は 0 から 32 までの任意の値)
- 123.123.123.123/255.255.255.255
- <ipv6-address>/n(ここで n は 0 から 128 までの任意の値)
IPバージョン4の場合、この関数は末尾の構成要素が欠落しているもの(つまり、「192.168.1」のように4オクテット未満のもの)も、ドットが続くかどうかに関わらず受け付けます。 その場合にネットマスクも指定されていない場合は、実際に渡されたオクテットの数(上記の例では、3 オクテットなので 24)がネットマスクとして設定されます。
isInSubnet()も参照してください 。
int QHostAddress::protocol() const
ホストアドレスのネットワーク層プロトコルを返します。
QString QHostAddress::scopeId() const
IPv6アドレスのスコープIDを返します。IPv4アドレスの場合、またはアドレスにスコープIDが含まれていない場合は、空のQString が返されます。
IPv6のスコープIDは、非グローバルなIPv6アドレスの到達可能範囲を指定し、そのアドレスが使用できる領域を制限します。すべてのIPv6アドレスには、このような到達可能範囲が関連付けられています。スコープIDは、グローバルに一意であることが保証されていないアドレスの曖昧さを解消するために使用されます。
IPv6 では、到達可能性について以下の 4 つのレベルが規定されています。
- ノードローカル:同じインターフェース上のサービスとの通信にのみ使用されるアドレス(例:ループバックインターフェース「::1」)。
- リンクローカル:ネットワークインターフェース(リンク)にローカルなアドレス。ホスト上の各IPv6インターフェースには、常に1つのリンクローカルアドレスが存在します。リンクローカルアドレス(「fe80...」)は、ローカルネットワークアダプタのMACアドレスから生成され、一意であることは保証されません。
- グローバル:インターネット上のパブリックサーバーなど、グローバルにルーティング可能なアドレスです。
IPv6 接続にリンクローカルアドレスまたはサイトローカルアドレスを使用する場合は、スコープ ID を指定する必要があります。 リンクローカルアドレスのスコープ ID は、通常、インターフェース名(例: 「eth0」、「en1」)または番号(例: 「1」、「2」)と同じです。
setScopeId()、QNetworkInterface 、およびQNetworkInterface::interfaceFromNameも参照してください 。
void QHostAddress::setAddress(quint32 ip4Addr)
ip4Addr で指定された IPv4 アドレスを設定します。
void QHostAddress::setAddress(QHostAddress::SpecialAddress address)
address で指定された特別なアドレスを設定します。
これはオーバーロードされた関数です。
bool QHostAddress::setAddress(const QString &address)
address で指定された文字列表現(例: "127.0.0.1")で表される IPv4 または IPv6 アドレスを設定します。アドレスの解析に成功した場合は `true ` を返し、アドレスを設定します。そうでない場合は `false` を返します。
これはオーバーロードされた関数です。
void QHostAddress::setAddress(const Q_IPV6ADDR &ip6Addr)
ip6Addr で指定された IPv6 アドレスを設定します。
これはオーバーロードされた関数です。
void QHostAddress::setAddress(const quint8 *ip6Addr)
ip6Addr で指定されたIPv6アドレスを設定します。
ip6Addr これは、ネットワークバイト順(上位バイトが先頭)の 16 バイトの配列でなければなりません。
これはオーバーロードされた関数です。
void QHostAddress::setAddress(const sockaddr *sockaddr)
ネイティブ構造体 `sockaddr` で指定された IPv4 または IPv6 アドレスを設定します。アドレスの解析に成功した場合は `true ` を返し、アドレスを設定します。そうでない場合は `false` を返します。
これはオーバーロードされた関数です。
void QHostAddress::setScopeId(const QString &id)
アドレスのIPv6スコープIDをid に設定します。アドレスのプロトコルがIPv6でない場合、この関数は何も行いません。 スコープIDは、インターフェース名(「eth0」や「en1」など)として、あるいはインターフェースインデックスを表す整数として設定できます。id がインターフェース名の場合、QtNetwork は、オペレーティングシステムのネットワーク関数を呼び出す前に、QNetworkInterface::interfaceIndexFromName() を使用してインターフェースインデックスに変換します。
scopeId()、QNetworkInterface 、およびQNetworkInterface::interfaceFromNameも参照してください 。
[noexcept] void QHostAddress::swap(QHostAddress &other)
このホストアドレスをother と入れ替えます。この操作は非常に高速で、失敗することはありません。
quint32 QHostAddress::toIPv4Address(bool *ok = nullptr) const
IPv4アドレスを数値として返します。
たとえば、アドレスが 127.0.0.1 の場合、戻り値は 2130706433 (すなわち 0x7f000001) となります。
この値は、protocol() の値がIPv4Protocol である場合、またはプロトコルがIPv6Protocol であり、IPv6 アドレスが IPv4 マッピングアドレス (RFC4291) である場合に有効です。これらの場合、ok は true に設定されます。それ以外の場合は、false に設定されます。
toString()も参照してください 。
Q_IPV6ADDR QHostAddress::toIPv6Address() const
IPv6アドレスをQ_IPV6ADDR構造体として返します。この構造体は、16個の符号なし文字で構成されています。
Q_IPV6ADDR addr = hostAddr.toIPv6Address();
// addr contains 16 unsigned characters
for (int i = 0; i < 16; ++i) {
// process addr[i]
}この値は、protocol() の引数が `IPv6Protocol` の場合に有効です。プロトコルが `IPv4Protocol` の場合、アドレスは IPv4 マッピングされた IPv6 アドレスとして返されます。(RFC4291)
toString()も参照してください 。
QString QHostAddress::toString() const
アドレスを文字列として返します。
たとえば、アドレスが IPv4 アドレスの 127.0.0.1 の場合、返される文字列は "127.0.0.1" となります。 IPv6 の場合、文字列の形式は RFC5952 の推奨事項に従います。QHostAddress::Any の場合、その IPv4 アドレス(「0.0.0.0」)が返されます。
toIPv4Address()も参照してください 。
bool QHostAddress::operator!=(QHostAddress::SpecialAddress other) const
指定されたother アドレスとこのホストアドレスが一致しない場合はtrue を返し、一致する場合はfalse を返します。
bool QHostAddress::operator!=(const QHostAddress &other) const
指定されたother アドレスとこのホストアドレスが一致しない場合はtrue を返し、一致する場合はfalse を返します。
QHostAddress &QHostAddress::operator=(QHostAddress::SpecialAddress address)
このオブジェクトに特別なアドレス `address ` を割り当て、このオブジェクトへの参照を返します。
setAddress()も参照してください 。
QHostAddress &QHostAddress::operator=(const QHostAddress &address)
このオブジェクトに別のホスト `address ` を割り当て、このオブジェクトへの参照を返します。
bool QHostAddress::operator==(QHostAddress::SpecialAddress other) const
このホストアドレスが指定されたother アドレスと一致する場合はtrue を返し、一致しない場合はfalse を返します。
bool QHostAddress::operator==(const QHostAddress &other) const
このホストアドレスが指定されたother アドレスと一致する場合、true を返します。一致しない場合は、false を返します。この演算子は、単にisEqual(other,StrictConversion) を呼び出すだけです。
isEqual()も参照してください 。
関連する非メンバー関数
[noexcept] size_t qHash(const QHostAddress &key, size_t seed = 0)
`key` のハッシュ値を返します。計算のシードには `seed ` を使用します。
bool operator!=(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)
特別なアドレスlhs がホストアドレスrhs と同一である場合は、false を返します。それ以外の場合は、true を返します。
isEqual()も参照してください 。
QDataStream &operator<<(QDataStream &out, const QHostAddress &address)
ホストアドレス `address ` をストリーム `out ` に書き込み、そのストリームへの参照を返します。
「Qt データ型のシリアライズ」も参照してください 。
bool operator==(QHostAddress::SpecialAddress lhs, const QHostAddress &rhs)
特別なアドレスlhs がホストアドレスrhs と同一である場合は、true を返します。それ以外の場合は、false を返します。
isEqual()も参照のこと 。
QDataStream &operator>>(QDataStream &in, QHostAddress &address)
ストリーム `in ` からホストアドレスを読み取り、address に格納し、そのストリームへの参照を返します。
「Qt データ型のシリアル化」も参照してください 。
© 2026 The Qt Company Ltd. Documentation contributions included herein are the copyrights of their respective owners. The documentation provided herein is licensed under the terms of the GNU Free Documentation License version 1.3 as published by the Free Software Foundation. Qt and respective logos are trademarks of The Qt Company Ltd. in Finland and/or other countries worldwide. All other trademarks are property of their respective owners.