Managing Data Collection Settings

To enable the use of the telemetry plugin, you need to select Enable Usage Statistics in the splash screen that appears when you first launch Qt Design Studio. If the splash screen does not appear, you can enable the telemetry plugin by selecting Help > About Plugins > Utilities > UsageStatistic.

"Enabling Usage Statistics"

Principles of Data Collection

No personal data, such as names, IP addresses, MAC addresses, or project and path names are collected. However, QUuid objects are used to identify data records that belong to one user. The objects cannot be converted back to the actual values from which they were generated.

For more information about Qt privacy policy, select Legal Notice and Privacy Policy.

Collecting Usage Statistics

The telemetry plugin uses the KUserFeedback framework to collect the usage data. The library has been designed from the user data privacy point of view and Qt Design Studio respects the same privacy rules.

The data is transmitted to the backend storage using an encrypted connection. The storage is located in the same Heroku backend as the Qt installer backend. Physically, data is stored in the Amazon cloud.

Specifying Telemetry Settings

To determine what data is transmitted to the backend storage:

  1. Select Tools > Options > Telemetry > Usage Statistics.

    "Telemetry settings"

  2. In the Telemetry mode list, select the mode that determines what kind of data is collected.
  3. In the Data sources list, select entries to view exactly what data is collected. Deselect check boxes for data that you do not want to transmit to the backend storage.

Reporting Crashes

You can enable Qt Design Studio to report crashes automatically. Qt Design Studio uses Google Crashpad to collect crashes and report them to the Sentry backend storage for processing. The purpose of Crashpad is to capture application state in sufficient detail to allow developers to diagnose and, where possible, fix the issue causing the crash. Crashpad may capture arbitrary contents from the memory of a crashed process, including user sensitive information, URLs, and other content provided by the users. The collected reports are used for the sole purpose of fixing bugs. For more information on Crashpad, see the documentation by Google. For more information on processing and storing of the collected data, see Security & Compliance by Sentry.

To enable sending crash reports, select Tools > Options > Environment > System (Qt Design Studio > Preferences > Environment > System on macOS), and then select Enable crash reporting.

Since crash reports take up disk space, you may wish to remove them when they are no longer needed. Select Clear local crash reports to remove the crash report data.

"Checkbox for enabling crash reporting"

Available under certain Qt licenses.
Find out more.