Setting Up Qt Bridge for Adobe Photoshop

Qt Bridge for Adobe Photoshop is included in the Qt Design Studio Enterprise license. You can use the Qt Installer to have the Qt Bridge for Adobe Photoshop plugin package copied to the following path in your Qt installation folder:

  • On Windows: Tools\QtDesignStudio\photoshop_bridge
  • On macOS: QtDesignStudio/photoshop_bridge.

Qt Bridge for Adobe Photoshop is delivered as an Adobe extension (ZXP) package and requires Adobe Photoshop version 20.0.0, or later to be installed. The Qt Bridge for Adobe Photoshop installation process differs depending on whether you are installing on Windows or macOS.

Installing on Windows

To install Qt Bridge for Adobe Photoshop on Windows:

  1. Copy the Qt Bridge for Adobe Photoshop ZXP package from Qt\Tools\QtDesignStudio\photoshop_bridge to the Documents directory in your user directory.
  2. Open Windows PowerShell.
  3. Enter the following commands:
    cd "$env:UserProfile\Documents"
    mv .\io.qt.QtBridge.zxp .\io.qt.QtBridge.zip
    expand-archive .\io.qt.QtBridge.zip
    xcopy /E /I .\io.qt.QtBridge  "$env:APPDATA\Adobe\CEP\extensions\io.qt.QtBridge"

Installing on macOS

To install Qt Bridge for Adobe Photoshop on macOS:

  1. Copy the Qt Bridge for Adobe Photoshop ZXP package from Qt/QtDesignStudio/photoshop_bridge to your Documents directory.
  2. Open Terminal.
  3. Enter the following commands:
    cd ~/Documents
    unzip io.qt.QtBridge.zxp -d io.qt.QtBridge
    sudo mkdir -p /Library/Application\ Support/Adobe/CEP/extensions
    sudo cp -R ./io.qt.QtBridge /Library/Application\ Support/Adobe/CEP/extensions

Note: On macOS Qt Bridge for Adobe Photoshop fails to load when Adobe Photoshop runs natively on an ARM processor (Apple silicon). For more information, see Running Qt Bridge for Adobe Photoshop on Apple Silicon.

Enabling Remote Connections

To set up Qt Bridge for Adobe Photoshop:

  1. Once the installation is completed, restart Adobe Photoshop to make Qt Bridge for Adobe Photoshop appear in Window > Extensions (Legacy).
  2. Select Edit > Preferences > General > Plug-ins to enable a remote connection.
  3. Select the Enable Remote Connections check box and enter a password in the Password field.
  4. To test that the connection is working properly, start Qt Bridge for Adobe Photoshop and select the settings icon in the top right corner.

  5. In the Password field, enter the password you entered in Adobe Photoshop and select Connect.
  6. In the Export Path group, select the folder button to specify the location where Qt Bridge for Adobe Photoshop copies the exported files.
  7. In the Asset format & scale group, select the default asset format (JPG, PNG, or SVG) and DPI to use for each layer.

Once the connection is successfully created, Qt Bridge for Adobe Photoshop is ready to use.

Running Qt Bridge for Adobe Photoshop on Apple Silicon

If you are using macOS on an ARM processor (Apple silicon), Qt Bridge for Adobe Photoshop may not be listed in Adobe Photoshop under Window > Extensions (Legacy). Run the Adobe Photoshop app in the Rosetta emulation mode. Right click the Adobe Photoshop.app and select Get info > Open using Rosetta. Once the app is running in the Rosetta emulation mode, make sure Preferences > Plug-ins > Legacy Extensions is selected.

Available under certain Qt licenses.
Find out more.